MongoDB.live, free & fully virtual. June 9th - 10th. Register Now

Realm TypeError Reflect.construct requires the first argument be a constructor

I reinstalled the MacOs operating system, my working code has failed.

I don’t understand, it was working before reinstalling.

My project detail is; “react”: “16.9.0” “react-native”: “0.61.1”, “realm”: “^3.6.5”,

I was tried realm 3.2.0 and 3.1.0 versions but not working, the same error persists.

my code is;

export function RealmDB_SetLoginUser(Data)
{
    realm.write(() =>
    {
        let LoginUser = realm.objects('LoginUser');

        realm.delete(LoginUser);

        realm.create('LoginUser', {
            Name: Data.Name,
            Password: Data.Password,
            IsTest: Data.IsTest,
        });
    });
}

Could you please help me?

Welcome to the community @Yusuf_Isik!

I see your question was asked (and answered) on Stack Overflow: TypeError: Reflect.construct requires the first argument be a constructor.

Regards,
Stennie