You need to bind the IP address to `127.0.0.1` or `localhost`

I am getting the bindIP address error but in mongod.log file shows as connection accepted localhost for 27000.

in /shared/mongod.config file I have mentioned the IP address given for lab,
bindIp: “127.0.0.1,192.168.103.100”

I am not understanding which config file it actually reads. /etc/mongo.cnf is a read only file and cannot be edited. Kindly help us to resolve the same asap.

Appreciate the kind help.

The config file is specified with –config or -f. For more details look at the Core Options section in https://docs.mongodb.com/manual/reference/program/mongod/.

Please show us how you started your mongod
Exact command or screenshot
Yes /etc/mongo.conf is a read only file(owned by root)
We can make our own config file using the contents of this file

1 Like

Thanks Rama for the revert, the issue got resolved :slight_smile:

I didn’t used bind_id parameter in the command. Config file was the next sub topic in the course.

1 Like