You need to bind the IP address to `127.0.0.1` or `localhost`

HI Team,

when im running the vagrant@m103:~$ validate_lab_launch_mongod . im receiving the below error .

You need to bind the IP address to 127.0.0.1 or localhost.

Can you please help to how to bind the ip .

i have tried to edit /etc/mongod.conf file to add ip adress as per the lab .but this file is having root permission. can you please let me where im doing mistake.

Please try to create your own config file

/etc/mongod.conf is owned by root and it is kind of master file
You need sudo privs to edit it

If you are using command line bind_ip is a parameter.You have to give IP,localhost
If you are using config file the parameter is bindIp

net:
bindIp:IP,localhost or 127.0.0.1

Please go thru your lectures on different parameters we pass while bringing up mongod

HI,

Seems to be im missing something or i didnt understand where to bind the ip . i have tried all options . still receiving the same error.

vagrant@m103:~ bind_ip=127.0.0.1 vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.
vagrant@m103:~ bind_ip=127.0.0.1,192.168.103.100 vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.
vagrant@m103:~ bind_ip=192.168.103.100 vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.
vagrant@m103:~ bind_ip=localhost,192.168.103.100 vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.
vagrant@m103:~ bind_ip=127.0.0.1,localhost vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.
vagrant@m103:~ bind_ip=192.168.103.100,localhost vagrant@m103:~ validate_lab_launch_mongod
You need to bind the IP address to 127.0.0.1 or localhost.

you need to set the […Deleted…] under net key in your configuration file

@prasantha_68763, the objective of this task is to lookup the mongod documentation where you’ll find the option to bind ips. This particular lab is not related to config files; that’s in the upcoming lab.

@Raghvendra_12694 it’s against forum guidelines to post potential answers to labs. Suggest you redact your post.

1 Like

HI I have gone through the doc . i have cleared it now .

Closing this thread as the issue has been resolved.