Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

Windows PHP startup error - unable to find module

help please.
i have windows 10 php 7 and mysql installed and all working fine.
i installed mongodb database and its operational, tested using compass.
i am now trying to use it from within php. i have used it before on an older machine successfully.
i downloaded mongodb.dll threadsafe64 - i thought the right one.
i put the extension parameter into ini file - =mongodb.dll
and then restarted all wamp services.
mongo driver is not loading and no sign in phpinfo().
in the php error log it says not found [di]r/mongodb.dll unable to load module.
i gathered this could be becuae i had installed the wrong version? i changed the name in the ini file to a rubbish name and tried again, same message.
the filename is correct and its in the right directory .
i then downlaoded a 32bit version (same name obviously) to see what would happen. this time it got a different message - about being wrong type. so its definitly going to the right place.

any ideas?
all i can now think of is that i am using the wrong wrong version of the dll, i tried to check the right version of the dll for php v7 but i couldnt trace what that should be.
do i need to put the pdb file there also?

thanks

exact error msg is
PHP Startup: Unable to load dynamic library ‘C:\wamp64\bin\php\php7.0.10\ext\php_mongodb.dll’ - The specified module could not be found.

in Unknown on line 0

the mongodb.dll version is 7.4.0

If the file is indeed in the exact path given above, then “the module could not be found” may not refer to the MongoDB extension itself, but one of its dependencies. As outlined in the Windows installation docs, the extension needs libsasl.dll to be found in the operating system’s PATH. Please check if the file is in the path and change the configuration if it isn’t. Thanks!

manyh thanks. i started looking as you suggested, then found a different version of the driver. i tried that and it all burst into life!

many thanks for responding.

it seems so hard to find proper list of dlls per php version per platform.

need to try PI next!

Pi working as well, but had to install full mongodb and then add the .so module to the ini