Win 10 installing vagrant plugin error: ssh version conflict

Hi. Installed SSH using the MinGW app as instructed, and when ssh run from command line, the one installed by MinGW is executed. So that seems right. But when I try to install the vagrant plugin, I get this error:

C:\Temp\m310-vagrant-env>vagrant plugin install vagrant-vbguest
Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
Vagrant failed to properly resolve required dependencies. These errors can commonly be caused by misconfigured plugin installations or transient network issues. The reported error is:

Unresolved dependency found during sorting - net-ssh (>= 2.6.5) (requested by net-scp-1.2.1)

Anyone have any ideas? Thanks!

Here is the execution of ssh from c: to show it’s running ok and env. variable is setup properly:

c:\>ssh
 usage: ssh [-1246AaCfgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]
         [-D [bind_address:]port] [-e escape_char] [-F configfile]
         [-I pkcs11] [-i identity_file]
          [-L [bind_address:]port:host:hostport]
          [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
          [-R [bind_address:]port:host:hostport] [-S ctl_path]
          [-W host:port] [-w local_tun[:remote_tun]]
          [user@]hostname [command]

c:

Could be version related issues or do you have other plugins installed
Please check this link.It may help

Some suggest to flush plugins or upgrade plugin

Hi, thanks for the reply. Turns out this was a bug in the Vagrant version 2.2.11 which I downloaded yesterday. The problem is documented in this link:

The problem is now fixed in version 2.2.13, and I was able to install the plugins with no error.