Why my chapter 1 lab failed

I Have everything setup correctly. Here is my screen shot:

MongoDB Enterprise > db.createUser({
… user: “m103-admin”,
… pwd: “m103-pass”,
… roles: [
… {role: “root”, db: “admin”}
… ]
… })
Successfully added user: {
“user” : “m103-admin”,
“roles” : [
{
“role” : “root”,
“db” : “admin”
}
]
}
MongoDB Enterprise > exit
bye
vagrant@m103:/data$ validate_lab_launch_mongod
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.
vagrant@m103:/data$ which validata_lab_lauch_mongod
vagrant@m103:/data$ ps -ef|grep mongod
vagrant 6483 1 1 15:48 ? 00:00:01 mongod --port 27000 --bind_ip 127.0.0.1,192.168.103.100 --dbpath /data/db --logpath /data/log1 --fork
vagrant 6533 6366 0 15:49 pts/0 00:00:00 grep --color=auto mongod
vagrant@m103:/data$ kill -9 6483
vagrant@m103:/data$ ps -ef|grep mongod
vagrant 6537 6366 0 15:53 pts/0 00:00:00 grep --color=auto mongod
vagrant@m103:/data$ mongod --auth --port 27000 --bind_ip 127.0.0.1,192.168.103.100 --dbpath /data/db --logpath /data/log1 --fork
about to fork child process, waiting until server is ready for connections.
forked process: 6540
child process started successfully, parent exiting
vagrant@m103:/data$ validate_lab_launch_mongod
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.

I suspect the user is not created in the appropriate database. Use getUsers() to see. The id should be admin.m103-admin.

THx. Actually I found out the root cause because the bind_ip syntax is wrong. After I fixed it, I can get the correct answer.

Thx again.

Closing this thread as the issue has been resolved.