Warnings when I am connected to primary node rs

Hi team,
When I connect to primary node I am getting this warnings.
It appears that every keep alive process launch the same warnings.
I have made the whole configuration process and I am getting the same result.

2019-05-22T16:46:48.813+0000 I NETWORK [thread1] Starting new replica set monitor for m103-repl/127.0.0.1:27001
2019-05-22T16:46:48.815+0000 I NETWORK [thread1] Successfully connected to 127.0.0.1:27001 (1 connections now open to 127.0.0.1:27001 with a 5 second timeout)
2019-05-22T16:46:48.815+0000 I NETWORK [thread1] changing hosts to m103-repl/192.168.103.100:27001,m103:27002,m103:27003 from m103-repl/127.0.0.1:27001
2019-05-22T16:46:48.816+0000 I NETWORK [thread1] Successfully connected to 192.168.103.100:27001 (1 connections now open to 192.168.103.100:27001 with a 5 second timeout)
2019-05-22T16:46:48.817+0000 W NETWORK [ReplicaSetMonitor-TaskExecutor-0] Failed to connect to 127.0.1.1:27003, in(checking socket for error after poll), reason: Connection refused
2019-05-22T16:46:48.819+0000 W NETWORK [ReplicaSetMonitor-TaskExecutor-0] Failed to connect to 127.0.1.1:27002, in(checking socket for error after poll), reason: Connection refused
Implicit session: session { “id” : UUID(“730b25fc-6706-48a9-8d8d-b9a94aac47a9”) }
MongoDB server version: 3.6.12
Server has startup warnings:
2019-05-22T16:45:40.726+0000 I STORAGE [initandlisten]
2019-05-22T16:45:40.726+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-05-22T16:45:40.726+0000 I STORAGE [initandlisten] ** See http://dochub.mongodb.org/core/prodnotes-filesystem
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten]
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/enabled is ‘always’.
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten] ** We suggest setting it to ‘never’
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten]
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/defrag is ‘always’.
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten] ** We suggest setting it to ‘never’
2019-05-22T16:45:42.354+0000 I CONTROL [initandlisten]
MongoDB Enterprise m103-repl:PRIMARY> 2019-05-22T16:47:18.821+0000 W NETWORK [ReplicaSetMonitor-TaskExecutor-0] Failed to connect to 127.0.1.1:27003, in(checking socket for error after poll), reason: Connection refused
2019-05-22T16:47:18.825+0000 W NETWORK [ReplicaSetMonitor-TaskExecutor-0] Failed to connect to 127.0.1.1:27002, in(checking socket for error after poll), reason: Connection refused

Thanks in advance.

I have just fixed it. It was a problem sin the configuration in the 2nd node.
Thanks

Hi,

I observed the same error message when I made the lab “Remove and Re-Add a Node” where we must remove one node (I chose 192.168.103.100:27003) and added it with m103:27003.

I passed that lab with the warning message. But afterward in lab “Writes with Failovers” and still get the warning and cannot connect directly to the secondary m103:27003.

I checked the /etc/hosts file in the vagrant box and this is what I got:

vagrant@m103:~$ cat /etc/hosts
127.0.1.1	m103.mongodb.university	m103
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 
::1       localhost localhost.localdomain localhost6 localhost6.localdomain6
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
192.168.103.100    m103 m103

It seems the name m103 is resolving to 127.0.1.1 hence the error. Is this a bug?

What did you change in the config file of the node exactly? the bindIp?