WARNING: shell and server versions do not match

I’m having this problem, when I try to access mongo shell, with the username and password (Windows user):

MongoDB shell version v4.4.1
connecting to: mongodb://sandbox-shard-00-00.xacaw.mongodb.net:27017,sandbox-shard-00-01.xacaw.mongodb.net:27017,sandbox-shard-00-02.xacaw.mongodb.net:27017/M001?authSource=admin&compressors=disabled&gssapiServiceName=mongodb&replicaSet=atlas-dreyvn-shard-0&ssl=true
Implicit session: session { “id” : UUID(“99771e93-d8e7-447f-9dfe-852505230aac”) }
MongoDB server version: 4.2.9
WARNING: shell and server versions do not match
Error while trying to show server startup warnings: user is not allowed to do action [getLog] on [admin.]

What can I do for this process?

You can ignore those warning messages
It will not affect your work
Were you able to connect?
You should have got mongo prompt

I can’t ignored the warning, because I can’t use and access the mongo shell by command

What can I do for that

So what error you get apart from that warning message.
Does it get hung there?
Have you whitelisted your IP
It could be firewall issue
Have you tried alternate network
I can connect to your cluster without any issues
I too get those warning message but that is not the cause for connection failure

1 Like

Hi @Arturo_Garcia,

Please provide the information requested by @Ramachandra_37567.