VT-x - Stderr: VBoxManage: error: VT-x is not available (VERR_VMX_NO_VMX) problem from Chapter 0: Introduction & Setup - Setting Up the Vagrant Environment

While trying on Windows set up (many problems that I could not continue) and now trying on ubuntu for Setting Up the Vagrant Environment. It’s terrible experience facing: VT-x problem that I have no way to set on VM machine of my Ubuntu 18.04. How many people experienced the similar issues? Any alternative? Such as container rather than Vagrant environment? Thank you.

err

Hi @Wei_95485,

Please make sure that virtualization has been enabled in BIOS and then restart your computer.

Hopefully this should resolve your issue.

One of our learners set up a docker environment for doing the labs. Please check this post.

Please feel free to get back to us if the issue still persists.

Thanks,
Shubham Ranjan
Curriculum Services Engineer

My Ubuntu is on VMware VM. Anyway that I can change the BIOS?

Hi @Wei_95485,

So, this is what it looks like :

Host OS -> Windows
VM -> Ubuntu

And you are trying to run the vagrant in your VM right ?

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Thank you Shubham!

The error comes from:

  1. Ubuntu 18.04 hosted on VMware
  2. Vagrant and VisualBox are installed on Ubuntu 18.04 of VMware machine

I followed the course instructions step by step.

By the way: I initially tried on Windows 7 with the latest Vagrant 2.x.x installed, the funny error showed it required release 3 that never exists! Wasted a lot of time and then gave up.

Possible that you guys can warp up the package in a docker container for us to install? That perhaps would be much easier than the picky Vagrant environment? If so, at least we can wait and skip this course first.

Best regards,

Hi @Wei_95485,

I’m sorry but in this case I don’t really have any debugging information available with me. You should probably reach out to the customer support of VMware to know more about how to enable virtualization in BIOS on a remote host.

We are currently developing our own IDE tool so that we can get rid of vagrant from this course. It would be available soon. And also did you check the link that I shared above for the docker environment ?

Thanks,
Shubham Ranjan
Curriculum Services Engineer

It gets a bit more complicated when it’s a nested VM but it’s possible. In VBox the settings for this is under System:
image
image
It should be in a similar place in VMWare Workstation.

I would also suggest that you decrease the amount of RAM you allocate. In VBox it’s here:
image

Than you for everyone’s help. It got it worked!

Hi @Wei_95485,

I’m glad your issue got resolved :clap: .

Can you please share the solution that worked for you so that it can help others in the forum ?

Thanks,
Shubham Ranjan
Curriculum Services Engineer