Virtualbox error

There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “49b59f83-788b-4995-b94a-aeba92e66d46”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: VT-x is not available (VERR_VMX_NO_VMX)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

Hi @Oyebamiji_57638,

I noticed that you have another thread re installation.

Are you actually no longer getting the “VT-x is not available” error? Did you turn on Virtualization?

Also confirm your OS and version.

yes i turned virtualization and unchecked hyper-V.
This is the error log i’m getting at the moment…

Stderr: 0%…
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Could not find Host Interface Networking driver! Please reinstall
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage.exe: error: Context: “enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)” at line 94 of file VBoxManageHostonly.cpp

Continue this conversation in your other thread or close it… you choose! But I need to know which action you’re taking.

?

we can continue the conversation here, if you don’t mind.

My operating system is Window 10 pro.

I restarted the system but not working yet

Please go into the thread, delete it and confirm when it’s done. You can do it via this button here:

Couple of things:

  1. After the restart, have you tried to reinstall VirtualBox?
  2. Open up Network Connections, and show us a screenshot. I want to see all the network connections beginning with VirtualBox, you can scrub off anything else you don’t want us to see.

Hi @Oyebamiji_57638,

As @007_jb mentioned, please do a fresh installation of VirtualBox after deleting the existing one. If it does not resolve the issue then please feel free to get back to us.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

I don’t understand what you’re trying to tell us here. Please add some comments. Is this after you did a fresh installation of VirtualBox as advised by myself and @Shubham_Ranjan?

I uninstalled the VirtualBox and reinstall again.
Then ran “vagrant up”, but still having the same issue.

You asked me to send a screenshot of it.

The screenshot of Network Connections is fine. However, the error has reverted back to the original error message and it’s pointing back to Virtualization being off and/or Hyper-V being on.

Suggest the following steps (in this specific order and without skipping a step):

  1. Right-click the Command Prompt (CMD) icon and click Run as Administrator
  2. Execute the following code in the CMD
    bcdedit /set hypervisorlaunchtype off
  3. Double check that Hyper-V is off:
    Click Windows > type Turn Windows Features and click on it > search for Hyper-V and make sure the box is not checked.
    image
  4. Restart your machine > go into your BIOS settings > find Virtualization and ensure it’s On
  5. Restart your machine once more
  6. Try vagrant again by running the following:
    vagrant destroy
    vagrant up

I followed the steps 1-6 but i’m still having the same error

Please share screenshots of 3, 4 and 6.

Also share the versions for VirtualBox and Vagrant.

Hi @Oyebamiji_57638,

What edition of Windows 10 are you using ? Is it Windows 10 Home ?

Thanks,
Shubham Ranjan
Curriculum Support Engineer