Validate_box not found

This did not fix my issue.
I still get this error:

validate_box: command not found

I see mongod-m103 running. Can anyone help me to get “validate_box” to work.
I started this course few months back and was unable to complete because of the same reason. Prompt response/help from MongoDB is greatly appreciated.

What does your vagrant status show
Can you paste how you are running that command
It could be path issue

Here is the output…

C02WT3B1HTD6MBP:/Users/axc08/university/m103/m103-vagrant-env> vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Running provisioner: shell…
mongod-m103: Running: /var/folders/cc/ys93h08j16j7jz10h73j2l7c0000gn/T/vagrant-shell20190413-19937-eybuj1
mongod-m103: + config
mongod-m103: + sudo su
mongod-m103: + echo -e never
mongod-m103: + echo -e never
mongod-m103: + echo manual
mongod-m103: + sudo tee /etc/init/mongod.override
mongod-m103: manual
mongod-m103: + ip_config
mongod-m103: ++ ifconfig
mongod-m103: ++ tail -1
mongod-m103: ++ awk ‘{ print $1}’
mongod-m103: ++ grep -v 127.0.0.1
mongod-m103: ++ cut -d: -f2
mongod-m103: ++ grep ‘inet addr:’
mongod-m103: + export CLIENT_IP_ADDR=192.168.103.100
mongod-m103: + CLIENT_IP_ADDR=192.168.103.100
mongod-m103: ++ hostname
mongod-m103: + export CLIENT_FQDN=m103
mongod-m103: + CLIENT_FQDN=m103
mongod-m103: ++ hostname
mongod-m103: ++ tr ‘[:upper:]’ ‘[:lower:]’
mongod-m103: ++ cut -d. -f 1
mongod-m103: + export CLIENT_NAME=m103
mongod-m103: + CLIENT_NAME=m103
mongod-m103: + echo ‘Configuring /etc/hosts …’
mongod-m103: Configuring /etc/hosts …
mongod-m103: + echo ‘127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ’
mongod-m103: + echo ‘::1 localhost localhost.localdomain localhost6 localhost6.localdomain6’
mongod-m103: + echo ‘fe00::0 ip6-localnet’
mongod-m103: + echo ‘ff00::0 ip6-mcastprefix’
mongod-m103: + echo ‘ff02::1 ip6-allnodes’
mongod-m103: + echo ‘ff02::2 ip6-allrouters’
mongod-m103: + echo ‘ff02::3 ip6-allhosts’
mongod-m103: + echo ‘192.168.103.100 m103 m103’
mongod-m103: + update_repo
mongod-m103: + echo ‘Install MongoDB Enterprise Repository’
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + echo ‘deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse’
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.O6YRhgJAex --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: gpg:
mongod-m103: requesting key 91FA4AD5 from hkp server keyserver.ubuntu.com
mongod-m103: gpg:
mongod-m103: key 91FA4AD5: “MongoDB 3.6 Release Signing Key packaging@mongodb.com” not changed
mongod-m103: gpg:
mongod-m103: Total number processed: 1
mongod-m103: gpg:
mongod-m103: unchanged: 1
mongod-m103: + echo ‘Update Repositories’
mongod-m103: Update Repositories
mongod-m103: + sudo apt-get update -y
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6 InRelease
mongod-m103: Hit http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release.gpg
mongod-m103: Hit http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release
mongod-m103: Hit http://security.ubuntu.com trusty-security InRelease
mongod-m103: Ign http://archive.ubuntu.com trusty InRelease
mongod-m103: Hit http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse amd64 Packages
mongod-m103: Hit http://security.ubuntu.com trusty-security/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-updates InRelease
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports InRelease
mongod-m103: Hit http://security.ubuntu.com trusty-security/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty Release.gpg
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main Sources
mongod-m103: Hit http://security.ubuntu.com trusty-security/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted Sources
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe Sources
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en_US
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty Release
mongod-m103: Hit http://archive.ubuntu.com trusty/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/universe Translation-en
mongod-m103: Ign http://archive.ubuntu.com trusty/main Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/restricted Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/universe Translation-en_US
mongod-m103: Reading package lists…
mongod-m103: + echo ‘Installing MongoDB Enterprise Dependencies’
mongod-m103: Installing MongoDB Enterprise Dependencies
mongod-m103: + sudo apt-get install -y libgssapi-krb5-2 libsasl2-2 libssl1.0.0 libstdc++6 snmp
mongod-m103: Reading package lists…
mongod-m103: Building dependency tree…
mongod-m103: Reading state information…
mongod-m103: libsasl2-2 is already the newest version.
mongod-m103: libgssapi-krb5-2 is already the newest version.
mongod-m103: libssl1.0.0 is already the newest version.
mongod-m103: libstdc++6 is already the newest version.
mongod-m103: snmp is already the newest version.
mongod-m103: 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
mongod-m103: + install_mongod
mongod-m103: + echo ‘Install MongoDB Enterprise’
mongod-m103: Install MongoDB Enterprise
mongod-m103: + sudo apt-get install --force-yes -y mongodb-enterprise
mongod-m103: Reading package lists…
mongod-m103: Building dependency tree…
mongod-m103: Reading state information…
mongod-m103: mongodb-enterprise is already the newest version.
mongod-m103: 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
mongod-m103: + mkdir -p /var/log/mongodb/
mongod-m103: + sudo chown vagrant:vagrant -R /var/log/mongodb
mongod-m103: + sudo chown vagrant:vagrant -R /var/lib/mongodb
mongod-m103: + sudo echo ’
mongod-m103: security:
mongod-m103: + sudo tee -a /etc/mongod.conf
mongod-m103: authorization: enabled’
mongod-m103:
mongod-m103: security:
mongod-m103: authorization: enabled
mongod-m103: + echo ‘Done installing MongoDB Enterprise’
mongod-m103: Done installing MongoDB Enterprise
mongod-m103: + user_setup
mongod-m103: + sudo sh -c ‘killall mongod; true’
mongod-m103: mongod: no process found
mongod-m103: + sudo mkdir -p /data
mongod-m103: + sudo chmod -R 777 /data
mongod-m103: + mkdir -p /data/db
mongod-m103: + mkdir -p /home/vagrant/data
mongod-m103: + chmod -R 777 /home/vagrant/data
mongod-m103: + chown -R vagrant:vagrant /home/vagrant/data
mongod-m103: + mkdir -p /var/m103/validation
mongod-m103: + echo ‘Set LC_ALL=C to .profile’
mongod-m103: Set LC_ALL=C to .profile
mongod-m103: + sudo echo ‘export LC_ALL=C’
mongod-m103: + sudo echo PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin:/var/m103/validation
mongod-m103: + data_path
mongod-m103: + sudo mkdir -p /data
mongod-m103: + sudo chown -R vagrant:vagrant /data
mongod-m103: + install_pymongo
mongod-m103: + sudo apt-get -y install python-pip
mongod-m103: Reading package lists…
mongod-m103: Building dependency tree…
mongod-m103: Reading state information…
mongod-m103: python-pip is already the newest version.
mongod-m103: 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
mongod-m103: + sudo pip install pymongo
mongod-m103: Requirement already satisfied (use --upgrade to upgrade): pymongo in /usr/local/lib/python2.7/dist-packages
mongod-m103: Cleaning up…
mongod-m103: + download_dataset
mongod-m103: + echo ‘Downloading Dataset’
mongod-m103: Downloading Dataset
mongod-m103: + curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.
C02WT3B1HTD6MBP:/Users/axc08/university/m103/m103-vagrant-env> curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz
C02WT3B1HTD6MBP:/Users/axc08/university/m103/m103-vagrant-env> ls -ltr
total 22696
-rw-r–r--@ 1 axc08 staff 811 Apr 12 22:08 Vagrantfile
-rw-r–r--@ 1 axc08 staff 4672 Apr 12 22:38 provision-mongod.orig
-rw-r–r--@ 1 axc08 staff 4783 Apr 12 22:39 provision-mongod
drwxr-xr-x 2 axc08 staff 64 Apr 12 22:42 shared
drwxr-xr-x 2 axc08 staff 64 Apr 12 22:42 dataset
-rw-r–r-- 1 axc08 staff 11314280 Apr 13 01:36 products.json.tgz
C02WT3B1HTD6MBP:/Users/axc08/university/m103/m103-vagrant-env> vagrant ssh
Welcome to Ubuntu 14.04.6 LTS (GNU/Linux 3.13.0-168-generic x86_64)

System information as of Sat Apr 13 05:36:06 UTC 2019

System load: 0.01 Processes: 84
Usage of /: 4.9% of 39.34GB Users logged in: 0
Memory usage: 8% IP address for eth0: 10.0.2.15
Swap usage: 0% IP address for eth1: 192.168.103.100

Graph this data and manage this system at:
https://landscape.canonical.com/

New release ‘16.04.6 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

Last login: Sat Apr 13 05:32:09 2019 from 10.0.2.2
vagrant@m103:~$

Thanks a lot for looking into this.
~amrita

May be some setup issues
Try to halt/suspend vagrant and start it by vagrant up

In my case when vagrant up is run i can see below

mongod-m103: Downloading Validation Scripts
mongod-m103: + curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/m103_validation.tgz -o m103_validation.tgz
mongod-m103: + tar -xzvf m103_validation.tgz -C /var/m103/validation
mongod-m103: ./._validate_lab_change_dbpath
mongod-m103: validate_lab_change_dbpath

This is how my provision set ended…



mongod-m103: Successfully installed pymongo
mongod-m103: Cleaning up…
mongod-m103: + download_dataset
mongod-m103: + echo ‘Downloading Dataset’
mongod-m103: Downloading Dataset
mongod-m103: + curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

I searched through the entire provision screen output and now where did i find “Downloading Validation Scripts” :frowning_face: Yuck!

Does MongoDB University team respond and help with issues?
I see many places Kanika keeps instructing to re-intall. Nowhere am I finding a fix to this. I did turn off firewall on my mac. Still same issue.

Thanks for your help!
~amrita

May be the process changed
Mine is a bit old output

Did you try to search for validate_box file?
Use find command and search from root dir /
What are contents of your /shared dir ?

Yes there are many threads suggesting reinstall,re-provision etc
Kanika may be able to help you out

Another option
Click on this link
https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/m103_validation.tgz

It is downloading the file
unzip it using winzip
or copy file to vagrant box(linux) and unzip it using
ex:
tar zxvf myfile.tgz
gunzip -c myfile.tgz | tar xvf -

replace myfile with m103_validation.tgz

Thanks a ton Ramachandran for your help in troubleshooting this issue with me. I truly appreciate it. I did something similar to what you suggested above, which helped me resolve the issue and I was able to proceed successfully.

This is what fixed my issue. Hopefully, it will help another frustrated one :slight_smile:

  1. From “~/university/m103/m103-vagrant-env/provision-mongod” I simulated these 2 functions:

function download_dataset() {
echo “Downloading Dataset”

curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz

tar -xzvf products.json.tgz -C /dataset
rm -rf products.json.tgz
}

function download_validators() {
echo “Downloading Validation Scripts”

curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/m103_validation.tgz -o m103_validation.tgz

tar -xzvf m103_validation.tgz -C /var/m103/validation
rm -rf m103_validation.tgz
echo “#!/bin/bash
# curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/m103_validation.tgz -o m103_validation.tgz
sudo tar -xzvf m103_validation.tgz -C /var/m103/validation
rm -rf m103_validation.tgz” > /var/m103/validation/download_validators
echo “#!/bin/bash
echo -n ‘m103 rocks’ | openssl sha256 | sed -e s/(stdin)=.//” > /var/m103/validation/validate_box
chmod -R +x /var/m103/validation/
chown root:root /var/m103/validation
echo “Done: Downloaded Validation Scripts”
}

  1. Downloaded products:

curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz

  1. Downloaded validation scripts:

curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/m103_validation.tgz -o m103_validation.tgz

  1. Copied the 2 files:

products.json.tgz
m103_validation.tgz

FROM: ~/university/m103/m103-vagrant-env/
TO: ~//university/m103/m103-vagrant-env/dataset

  1. These 2 files now showed up inside the VM in data set directory:

vagrant@m103:/dataset$ ls -ltr
-rw-r–r-- 1 vagrant vagrant 92216793 Mar 5 2018 products.json.tgz
-rw-r–r-- 1 vagrant vagrant 20966321 Apr 13 16:37 m103_validation.tgz

  1. untarred validation scripts:

vagrant@m103:/dataset$ sudo tar -xzvf m103_validation.tgz -C /var/m103/validation

  1. Untarred products file, to be later used in one of the labs:

vagrant@m103:/dataset$ sudo tar -xzvf products.json.tgz

  1. Got the hash key for validate_box:

vagrant@m103:/dataset$ echo -n ‘m103 rocks’ | openssl sha256 | sed -e s/(stdin)=.//

  1. Created the validate_box file with that key:

vagrant@m103:/dataset$ cat /var/m103/validation/validate_box

#!/bin/bash
echo -n 6445a3f8b6f1cc5873cf1ac94194903444602708d4eb189d42b6e65ca594d80d

  1. Changed perms & ownership:

vagrant@m103:/dataset$ sudo chmod -R +x /var/m103/validation/
vagrant@m103:/dataset$ sudo chown root:root /var/m103/validation

I was able to proceed thereon…

Thanks a ton again!
~amrita

1 Like

Incredibly, I seem to be able to solve this by running the command again
vagrant up --provision

I have tried a number of the recommended solutions and I still cannot get Vagrant to provision properly. Still receiving the following:

mongod-m103: + echo 'Install MongoDB Enterprise Repository'
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + echo 'deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse'
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.9H1HG3lYbd --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: gpg:
mongod-m103: requesting key 91FA4AD5 from hkp server keyserver.ubuntu.com
mongod-m103: ?:
mongod-m103: keyserver.ubuntu.com: Host not found
mongod-m103: gpgkeys: HTTP fetch error 7: couldn't connect: Success
mongod-m103: gpg:
mongod-m103: no valid OpenPGP data found.
mongod-m103: gpg:
mongod-m103: Total number processed: 0

The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Any thoughts on how best to proceed?

@Kanika

Hi @Blake_99043,

Are you able to access this link?
Please make sure that you are not behind any firewall or in office network. Try to start vagrant in home or personal network.

If you still face any problem, please let me know.

Thanks,
Sonali

Yes…no problem.


Sincerely, Blake Racich

IBM Corporation

Same result:

mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.3qEjcBFeRP --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5
mongod-m103: gpg:
mongod-m103: requesting key 91FA4AD5 from hkp server keyserver.ubuntu.com
mongod-m103: ?:
mongod-m103: keyserver.ubuntu.com: Host not found
mongod-m103: gpgkeys: HTTP fetch error 7: couldn't connect: Success
mongod-m103: gpg:
mongod-m103: no valid OpenPGP data found.
mongod-m103: gpg: Total number processed: 0

The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Hi @Blake_99043,

Have you tried this?

Also, check below links:

https://ubuntuforums.org/showthread.php?t=1437659

Let me know if it works!

Kanika

So, it looks like I’m now passed the initial issue by using an IP address:
sudo gpg --keyserver hkp://192.146.137.98 --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3

But onto another issue as I don’t think that it is loading repositories or doing what it should be doing.

I can ssh to Vagrant but there is nothing in there when I check ‘validate_box’.

Let me know how best to proceed.

mongod-m103: Update Repositories
mongod-m103: + sudo apt-get update -y
mongod-m103: Err http://repo.mongodb.com trusty/mongodb-enterprise/3.6 InRelease
mongod-m103:
mongod-m103: Err http://security.ubuntu.com trusty-security InRelease
mongod-m103:
mongod-m103: Err http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release.gpg
mongod-m103:   Could not resolve 'repo.mongodb.com'
mongod-m103: Err http://archive.ubuntu.com trusty InRelease
mongod-m103:
mongod-m103: Err http://security.ubuntu.com trusty-security Release.gpg
mongod-m103:   Could not resolve 'security.ubuntu.com'

@Kanika - any ideas / updates etc.? I still don’t have the ability to set up an environment in which to even start my class. Please let me know. Thanks much.

i am using windows 10, getting error URL: [“https://vagrantcloud.com/ubuntu/trusty64”]
Error: Could not resolve host: vagrantcloud.com

Oh my god, you guys!!! After reading this entire thread, I restarted my laptop and run vagrant up --provision again. And it worked all the way to validate_box. I highly suggest to try restarting and do vagrant up --provision.
Good luck!

2 Likes

This worked for me correctly

I am using window X and while running vagrant up–>Getting below error:-

Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured (“config.vm.boot_timeout” value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you’re using a custom box, make sure that networking is properly
working and you’re able to connect to the machine. It is a common
problem that networking isn’t setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout (“config.vm.boot_timeout”) value.

========================================================
And the running–> vagrant status–> Getting below success message

mongod-m103 running (virtualbox)

The VM is running. To stop this VM, you can run vagrant halt to
shut it down forcefully, or you can run vagrant suspend to simply
suspend the virtual machine. In either case, to restart it again,
simply run vagrant up.

====================================================

C:\Users\Rohit\Desktop\MongoDB\M103_Cluster\m103\m103-vagrant-env>vagrant provision
==> mongod-m103: Running provisioner: shell…
An error occurred in the underlying SSH library that Vagrant uses.
The error message is shown below. In many cases, errors from this
library are caused by ssh-agent issues. Try disabling your SSH
agent or removing some keys and try again.

If the problem persists, please report a bug to the net-ssh project.

timeout during server version negotiating

C:\Users\Rohit\Desktop\MongoDB\M103_Cluster\m103\m103-vagrant-env>

how can i resolve this error?

Hi @Rohit_84793,

Can you please try re-provisioning your vagrant?
You may also refer to this link - Vagrant Issues on Windows

Please let me know if you still face any issues.

Thanks,
Muskan
Curriculum Support Engineer