Validate_box not found

AM I the only one or does the command “validate_box” not exist? My vagrant environment works but have not been able to get past the Lab. I’ve searched online for the command with no luck. I did find the “vagrant validate” command which works but does not give me a validation key as asked

Can you try re-running vagrant up —provision from your host OS? That will pull in any missing files.

The validation commands should be run from the Linux shell prompt in the Vagrant VM.

Hi @Tess_Sluijter . I’ve certainly tried this over and over again. Here are some errors I think mightbe related, while provisioning

W: GPG error: http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 58712A2291FA4AD5

and

WARNING: The following packages cannot be authenticated!
mongod-m103: mongodb-enterprise-tools
mongod-m103: E
mongod-m103: :
mongod-m103: There are problems and -y was used without --force-yes
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

I also can’t find the log file so not sure how to tackle this. This is clearly a stopper for me on this course if I can’t resolve this

Blegh… third person I see to run into issues with the repos. I’ve already pinged a number of stuff about this.

Wow. Glad to hear I’m not the only one. was losing my mind on this

This issue is with MongoDB and not with vagrant. I already have opened a thread and link can be found below:

No affirmative response/solution from anyone so far…

To other students running into the same issue, please file a report inside the M103 training.

Same issue to me. I already reported the issue ubut as deadline is in 24 hours I’m wonder how can afford the taskes.

My outbut after vagrant up --provision is:
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Running provisioner: shell…
mongod-m103: Running: C:/Users/DANIEL/AppData/Local/Temp/vagrant-shell20190217-7536-1pyc8a9
mongod-m103: + config
mongod-m103: + sudo su
mongod-m103: + echo -e never
mongod-m103: + echo -e never
mongod-m103: + echo manual
mongod-m103: + sudo tee /etc/init/mongod.override
mongod-m103: manual
mongod-m103: + ip_config
mongod-m103: ++ ifconfig
mongod-m103: ++ grep ‘inet addr:’
mongod-m103: ++ grep -v 127.0.0.1
mongod-m103: ++ awk ‘{ print $1}’
mongod-m103: ++ cut -d: -f2
mongod-m103: ++ tail -1
mongod-m103: + export CLIENT_IP_ADDR=192.168.103.100
mongod-m103: + CLIENT_IP_ADDR=192.168.103.100
mongod-m103: ++ hostname
mongod-m103: + export CLIENT_FQDN=m103
mongod-m103: + CLIENT_FQDN=m103
mongod-m103: ++ hostname
mongod-m103: ++ tr ‘[:upper:]’ ‘[:lower:]’
mongod-m103: ++ cut -d. -f 1
mongod-m103: + export CLIENT_NAME=m103
mongod-m103: + CLIENT_NAME=m103
mongod-m103: + echo ‘Configuring /etc/hosts …’
mongod-m103: Configuring /etc/hosts …
mongod-m103: + echo '127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ’
mongod-m103: + echo ‘::1 localhost localhost.localdomain localhost6 localhost6.localdomain6’
mongod-m103: + echo ‘fe00::0 ip6-localnet’
mongod-m103: + echo ‘ff00::0 ip6-mcastprefix’
mongod-m103: + echo ‘ff02::1 ip6-allnodes’
mongod-m103: + echo ‘ff02::2 ip6-allrouters’
mongod-m103: + echo ‘ff02::3 ip6-allhosts’
mongod-m103: + echo ‘192.168.103.100 m103 m103’
mongod-m103: + update_repo
mongod-m103: + echo ‘Install MongoDB Enterprise Repository’
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + echo ‘deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse’
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.Xx9YkKB78e --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server keyserver.ubuntu.com
mongod-m103: ?:
mongod-m103: keyserver.ubuntu.com: Host not found
mongod-m103: gpgkeys: HTTP fetch error 7: couldn’t connect: Success
mongod-m103: gpg:
mongod-m103: no valid OpenPGP data found.
mongod-m103: gpg:
mongod-m103: Total number processed: 0
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Hi Wolfdaniel,

Can you please check if you are able to access “http://keyserver.ubuntu.com/”. Check for firewall and anti-virus issues.

Kanika

HI I have access it was not a firewall/antivirus issue I found the solution it was the function update_repo()
I change this line:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6

For this one


sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6

and it works. Now I’ll try to finish the labs before deadlines :cry: hehe

3 Likes

Nice going! Great that you fixed it!

@Kanika we should make a note of this…

Sure. Let me confirm this with the team and I will update you guys!

Thanks Wolfdaniel for so much troubleshooting and this helpful solution.

Kanika

1 Like

Hello I tried this out and I still get the same error.
I made changes to the update_repo function and restarted vagrant. I got the same error:

mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.zQ7ixbZa6r --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server keyserver.ubuntu.com
mongod-m103: gpg: key A15703C6: “MongoDB 3.4 Release Signing Key packaging@mongodb.com” not changed
mongod-m103: gpg: Total number processed: 1
mongod-m103: gpg: unchanged: 1
mongod-m103: + echo ‘Update Repositories’
mongod-m103: Update Repositories
mongod-m103: + sudo apt-get update -y
mongod-m103: Ign http://archive.ubuntu.com trusty InRelease
mongod-m103: Hit http://security.ubuntu.com trusty-security InRelease
mongod-m103: Hit http://archive.ubuntu.com trusty-updates InRelease
mongod-m103: Hit http://archive.ubuntu.com trusty-backports InRelease
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6 InRelease
mongod-m103: Hit http://security.ubuntu.com trusty-security/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty Release.gpg
mongod-m103: Get:1 http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release.gpg [801 B]
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main Sources
mongod-m103: Hit http://security.ubuntu.com trusty-security/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted Sources
mongod-m103: Hit http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe Sources
mongod-m103: Hit http://security.ubuntu.com trusty-security/main Translation-en
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse amd64 Packages/DiffIndex
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse Sources
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-updates/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty Release
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse Sources
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse Translation-en
mongod-m103: Hit http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe Translation-en
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en_US
mongod-m103: Hit http://archive.ubuntu.com trusty/main Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted Sources
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/universe Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse Sources
mongod-m103: Hit http://archive.ubuntu.com trusty/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/universe Translation-en
mongod-m103: Ign http://archive.ubuntu.com trusty/main Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/restricted Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/universe Translation-en_US
mongod-m103: Fetched 801 B in 36s (21 B/s)
mongod-m103: Reading package lists…
mongod-m103: W: GPG error: http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 58712A2291FA4AD5
mongod-m103: + echo ‘Installing MongoDB Enterprise Dependencies’
mongod-m103: Installing MongoDB Enterprise Dependencies
mongod-m103: + sudo apt-get install -y libgssapi-krb5-2 libsasl2-2 libssl1.0.0 libstdc++6 snmp
mongod-m103: Reading package lists…
mongod-m103: Building dependency tree…
mongod-m103: Reading state information…
mongod-m103: libsasl2-2 is already the newest version.
mongod-m103: libgssapi-krb5-2 is already the newest version.
mongod-m103: libssl1.0.0 is already the newest version.
mongod-m103: libstdc++6 is already the newest version.
mongod-m103: snmp is already the newest version.
mongod-m103: The following packages were automatically installed and are no longer required:
mongod-m103: mongodb-enterprise-mongos mongodb-enterprise-server mongodb-enterprise-shell
mongod-m103: mongodb-enterprise-tools
mongod-m103: Use ‘apt-get autoremove’ to remove them.
mongod-m103: The following extra packages will be installed:
mongod-m103: mongodb-enterprise-tools
mongod-m103: The following packages will be upgraded:
mongod-m103: mongodb-enterprise-tools
mongod-m103: 1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
mongod-m103: 1 not fully installed or removed.
mongod-m103: Need to get 0 B/46.3 MB of archives.
mongod-m103: After this operation, 189 MB of additional disk space will be used.
mongod-m103: WARNING: The following packages cannot be authenticated!
mongod-m103: mongodb-enterprise-tools
mongod-m103: E
mongod-m103: :
mongod-m103: There are problems and -y was used without --force-yes
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

This is getting too complicated and I don’ think I can proceed with the class to much time lost

1 Like

Hi there!

Sorry that you are having difficulties with vagrant. Could you please try the following:

In the provision-mongod file, replace the following line(57):

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6

with the following line:

 sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5

Once you have done this, please try to reprovision the box and let us know how it goes.

We are standing by to help should you hit any further issues.

3 Likes

I am still getting the same issue …

mongod-m103: + sudo echo ‘export LC_ALL=C’
mongod-m103: + sudo echo PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin:/var/m103/validation
mongod-m103: + data_path
mongod-m103: + sudo mkdir -p /data
mongod-m103: + sudo chown -R vagrant:vagrant /data
mongod-m103: + install_pymongo
mongod-m103: + sudo apt-get -y install python-pip
mongod-m103: Reading package lists…
mongod-m103: Building dependency tree…
mongod-m103:
mongod-m103: Reading state information…
mongod-m103: python-pip is already the newest version.
mongod-m103: 0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
mongod-m103: + sudo pip install pymongo
mongod-m103: Downloading/unpacking pymongo
mongod-m103: Cannot fetch index base URL https://pypi.python.org/simple/
mongod-m103: Could not find any downloads that satisfy the requirement pymongo
mongod-m103: Cleaning up…
mongod-m103: No distributions at all found for pymongo
mongod-m103: Storing debug log for failure in /root/.pip/pip.log
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Is there a new fix for this?

Please try from your home network or disable firewall/anit-virus.

Kanika

I tried again last night, didn’t change anything and it just worked. I don’t understand it but i only have one day left to get things done so i’m not questioning right now. :slight_smile: Thanks for the reply!

In that case, I only suspect network being the issue. Let me know if you again have this problem.

Kanika

Hi,
This line solve the problem.

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5