Vagrant & VirtualBox issues: dreadful!

Hi

I spent a lot of hours trying to prepare this (terrible) environment.

I’m getting the errors below when trying “vagrant up”

Vagrant 2.2.4
O.S. Win 7 SP1
Virtual Box 5.1.38

I’ve tried several version combinations (as mentioned in other thread). Unsuccessfully

Please provide the compatibility matrix of the products or any other suggestions that solve these problems.

Thank you very much
Andrea

Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘ubunt/trusty64’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
The box ‘ubunt/trusty64’ could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp’s Vagrant Cloud, please verify you’re logged in via
vagrant login. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: [“https://vagrantcloud.com/ubunt/trusty64”]
Error: The requested URL returned error: 404 Not Found

Really the URL “https://vagrantcloud.com/ubunt/trusty64” does not exist!
Getting

404 Not Found

Sorry, the page /ubunt/boxes/trusty64 could not be found.

This error could mean one of three things:

  • The resource doesn’t exist
  • The resource exists, but requires proper authorization to access
  • The resource exists, but its owner organization is delinquent

If someone has linked you to this resource, ensure that they have given you proper permissions to access it.

Hi @Ing_Giovanni_Andrea_Floriddia_67481,

Sorry for the trouble you are facing.

There seems to be a typo of ubunt. This url works for me:

https://vagrantcloud.com/ubuntu/trusty64

Can you please correct this in your Vagrantfile? The file will be in your handout downloaded from Lab: Setting Up Vagrant Environment.

Below are the contents of my Vagrantfile:

if Vagrant::VERSION < "2.0.0"
  $stderr.puts "Must redirect to new repository for old Vagrant versions"
  Vagrant::DEFAULT_SERVER_URL.replace('https://vagrantcloud.com')
end

Vagrant.configure("2") do |config|
  config.vm.box = "ubuntu/trusty64"
  config.vm.box_check_update = false
  config.vm.synced_folder "shared/", "/shared", create: true
  config.vm.synced_folder "dataset/", "/dataset", create: true

  config.vm.define "mongod-m103" do |server|
    server.vm.provider "virtualbox" do |vb|
	     vb.customize ["modifyvm", :id, "--cpus", "2"]
       vb.name = "mongod-m103"
       vb.memory = 2048
    end
    server.vm.hostname = "m103.mongodb.university"
    server.vm.network :private_network, ip: "192.168.103.100"
    server.vm.provision :shell, path: "provision-mongod", args: ENV['ARGS']
  end
end

Let me know if that works! If not, don’t worry, we will do our best to resolve the issue and get your vagrant up and running.

Kanika

Hi Kanika

Thank you very moch for your support!
I’ve just copied the content of your Vagrantfile and now the command “vagrant up” works!

Maybe there was some hidden character in the content of my file…

Very good!
Now I can work and continue with the course!

Thanks a lot
Andrea