Vagrant-vbguest plugin installation error

Hi,

I am trying to run “vagrant plugin install vagrant-vbguest” and its failing with below mentioned error. I am using Ubuntu 18.04.1 OS.

Error -
Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0)
Activated fog-core-1.45.0
which does not match conflicting dependency (~> 1.43.0)

Conflicting dependency chains:
fog-core (= 1.45.0), 1.45.0 activated

versus:
vagrant-libvirt (> 0), 0.0.41 activated, depends on
fog-core (~> 1.43.0)
+++++++++++++++++++++++++++++++++=

And also, shared folder mount is failing for infrastructure machine with below error and trouble shooting mentioned are not working.

Error -
Vagrant was unable to mount VirtualBox shared folders. This is usually (Vagrant::Errors::VirtualBoxMountFailed)
because the filesystem “vboxsf” is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 home_vagrant_shared /home/vagrant/shared

I assume that you are behind a proxy server,

If so try…
$proxyserver = “http://[server]:[port]”
$env:http_proxy = $proxyserver
$env:https_proxy = $proxyserver
vagrant plugin install vagrant-vbguest
vagrant plugin install vvagrant-proxyconf
$env:VAGRANT_HTTP_PROXY=$proxyserver
$env:VAGRANT_NO_PROXY=“127.0.0.1”
vagrant up

Before you run vagrant up you can check to make sure that the required plugins are installed…

vagrant plugin list

it should show

vagrant-vbguest
vvagrant-proxyconf
1 Like

It seems if you are behind a proxy you also need to add the following lines to

provision-infrastructure
export http_proxy=http://[server]:3128
export https_proxy=http://[server]:3128
between line 57 and 58

After that everything finally built correctly for me.

Hi anudeepsp,

It could be that the issue with the shared folder on the infrastructure machine is related to not having the plugin

vagrant-vbguest

Regarding the issue with installing the plugin.

What version of vagrant are you using ?

A couple of things to check:

  • Have you just tried re-running !
  • Harroguk’s suggestion if you’re behind a proxy server (@Harroguk- thanks for suggestion)
  • From a previous class where a student’s host was ubuntu they needed to disable IPv6 to enable download of plugin.
  • Also, I’ve found a couple post related to that specific error message that may help (See below)

Hope that helps

David


@Harroguk - Thank you for your suggestion. I am not behind the proxy server and it was the issue with vagrant version.

@dschupp - Issue resolved! (OS - Ubuntu 18.04.1)
My existing vagrant version was 2.0.2 which I used for M103. I installed vagrant 2.0.3 directly from hashicorp and then I am able to install vagrant-vbguest plugin.

Steps followed -

$wget -c https://releases.hashicorp.com/vagrant/2.0.3/vagrant_2.0.3_x86_64.deb

$sudo dpkg -i vagrant_2.0.3_x86_64.deb

$ vagrant plugin install vagrant-vbguest
==> vagrant: A new version of Vagrant is available: 2.1.5!
==> vagrant: To upgrade visit: https://www.vagrantup.com/downloads.html

Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
Fetching: micromachine-2.0.0.gem (100%)
Fetching: vagrant-vbguest-0.16.0.gem (100%)
Installed the plugin ‘vagrant-vbguest (0.16.0)’!

$ vagrant plugin list
vagrant-vbguest (0.16.0)

Once the plugins got installed - did below steps and everything works fine now!
$vagrant destroy
$vagrant up

3 Likes

@anudeepsp

Glad you got it working and thanks for sharing the resolution !

David

I had the exact same problem (on Ubuntu 18.04) and this solution helped. Thanks @anudeepsp

I’ve had the same issue, on bionic as well.

It seems to be an issue that was corrected on v2.0.3 update.

I had the exact same issue with my ubuntu 18.04 and vagrant 2.0.2.
It worked for me after upgrading the vagrant version to 2.0.3.
Thanks.