Vagrant up giving error

getting below error when i try to vagrant up. can anyone can help

==> infrastructure: Booting VM…
==> infrastructure: Waiting for machine to boot. This may take a few minutes…
infrastructure: SSH address: 127.0.0.1:2200
infrastructure: SSH username: vagrant
infrastructure: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured (“config.vm.boot_timeout” value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you’re using a custom box, make sure that networking is properly
working and you’re able to connect to the machine. It is a common
problem that networking isn’t setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout (“config.vm.boot_timeout”) value.

The error you got is a generic.Issue may be something else
Is the issue with only infrastructure or both infra & database?

Please go thru our forum threads.Many threads available on timeout error
Have you installed vbguest plugin
What are the instructions?
I think you have to bring up database first
Then apply vbguest plugin and bring up infra
Also have you enabled virtualiztion in bios and hyper-v is turned off

1 Like

Thnaks Ramachandra for the replay…

when i am installing the database and infrastructure. i am able to ssh to database but not infrastructure. please find below information.

==> infrastructure: Waiting for machine to boot. This may take a few minutes…
infrastructure: SSH address: 127.0.0.1:2200
infrastructure: SSH username: vagrant
infrastructure: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured (“config.vm.boot_timeout” value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you’re using a custom box, make sure that networking is properly
working and you’re able to connect to the machine. It is a common
problem that networking isn’t setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout (“config.vm.boot_timeout”) value.

E:\Study\mongoDB\test\m310-vagrant-env>vagrant ssh database
Welcome to Ubuntu 14.04.6 LTS (GNU/Linux 3.13.0-170-generic x86_64)

System information as of Sun Dec 13 07:15:03 UTC 2020

System load: 0.36 Processes: 81
Usage of /: 3.6% of 39.34GB Users logged in: 0
Memory usage: 12% IP address for eth0: 10.0.2.15
Swap usage: 0%

Graph this data and manage this system at:
https://landscape.canonical.com/

UA Infrastructure Extended Security Maintenance (ESM) is not enabled.

0 updates can be installed immediately.
0 of these updates are security updates.

Enable UA Infrastructure ESM to receive 64 additional security updates.
See https://ubuntu.com/advantage or run: sudo ua status

New release ‘16.04.7 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

vagrant@database:~$ exit
logout
Connection to 127.0.0.1 closed.

E:\Study\mongoDB\test\m310-vagrant-env>vagrant ssh infrastructure
ssh_exchange_identification: read: Connection reset

E:\Study\mongoDB\test\m310-vagrant-env>vagrant ssh infrastructure
ssh_exchange_identification: read: Connection reset

E:\Study\mongoDB\test\m310-vagrant-env>

Hi @Shree_Harsha,

I found this link useful to resolve this issue:

If you still have any issues, please feel free to reach out.

Kind Regards,
Sonali

Please refer to this link. It worked for me.

Post above change in VirtualBox version, you might face issue in umount stage. For which below link will help to fix it.

Hi,

I’ll add to this as I’m seeing same error on my lenovo laptop with Windows10 - after awhile.

Over the past few days, vagrant and vbox will work, and then after some time, it’ll stop working with the ssh errors. Reboot did not help. I have been working on HW… and then taking a lengthy break, and then is stops working. Even restarting from vbox would not work either. Internet search also showed hits to make sure your Power Management isn’t restricted - I set my to max .

My workaround - launch virtual box, right click on the ‘vm’ and Remove - Delete all the files.
And then remove/delete the ‘.vagrant’ directory from m310-vagrant-env directory. Basically starting over - on the plus side, at least for me, repetition definitely helps with my retention.

However, infrastructure doesn’t start - I’m getting a kernel panic (not at the disco). I’m thinking the workaround here is to use another machine.

Other quirks: after some time, my cmd window will stop accepting input…no worries - kill it, and launch another.

-JohnR