Vagrant up - giving error message

Hi,
I’m receiving below message when I run vagrant up:
\M103\m103-vagrant-env> vagrant up
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
mongod-m103: Box Provider: virtualbox
mongod-m103: Box Version: >= 0
The box ‘ubuntu/trusty64’ could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp’s Vagrant Cloud, please verify you’re logged in via
vagrant login. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: [“https://vagrantcloud.com/ubuntu/trusty64”]
Error: SSL certificate problem: self signed certificate in certificate chain

Some people experienced this problem and most of the time it was related to firewall issues, local to your machine or even from your work place. First thing to try is to disable local firewall if any while doing setup. Make sure you reactivate your security once it is done.

Hi,
I did turn off firewall and tried but still seeing the same error.
C:\Users\mohan\M103\m103-vagrant-env>vagrant up
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
mongod-m103: Box Provider: virtualbox
mongod-m103: Box Version: >= 0
The box ‘ubuntu/trusty64’ could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp’s Vagrant Cloud, please verify you’re logged in via
vagrant login. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: [“https://vagrantcloud.com/ubuntu/trusty64”]
Error: SSL certificate problem: self signed certificate in certificate chain

Can you access this URL from a browser?

@steevej-1495 - Yes, I’m able to access the given URL from the browser.

Any update to me to resolve the issue I’m facing with Vagrant setup ? Thanks

Sorry it is too deep for me. If removing firewall or other security measures I really do not know.

Hi @Mohan_47565,

Please check for anit-virus or firewall that might be blocking the issue:

If you have already checked, then as suggested please perform:

  vagrant login

username: vagrant
password: vagrant

Kanika

@Kanika - thanks for the info. Yes , I did disable my antivirus until I complete performing vagrant up and it ran successfully, then I enabled antivirus. Afterwards I did see other issue but after I enable Virtualization through BIOS , I was successfully continue with courses and labs.

Thanks all and @steevej-1495 !

2 Likes

Solve this problem by just closing Powershell (or CMD) and then opening it again