Vagrant up error - Is Windows10 Home Unsupported

FYI. from Task Manager I can see Virtualization is Enabled. It is also enabled on the BIOS.

C:\MinGW>set path
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files\Git\cmd;C:\WINDOWS\System32\OpenSSH;C:\HashiCorp\Vagrant\bin;“C:\Users\edwin\AppData\Local\Microsoft\WindowsApps;C:\MinGW\msys\1.0\bin”;C:\Program Files\Docker Toolbox;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

C:\MinGW>cd\mongodb

C:\MongoDB>cd m103

C:\MongoDB\m103>dir
Volume in drive C is Windows
Volume Serial Number is C8EC-DF10

Directory of C:\MongoDB\m103

13/04/2019 07:01 AM .
13/04/2019 07:01 AM …
13/04/2019 07:00 AM 4,672 provision-mongod
13/04/2019 07:00 AM 811 Vagrantfile
2 File(s) 5,483 bytes
2 Dir(s) 1,840,547,557,376 bytes free

C:\MongoDB\m103>vagrant up
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
mongod-m103: Box Provider: virtualbox
mongod-m103: Box Version: >= 0
==> mongod-m103: Loading metadata for box ‘ubuntu/trusty64’
mongod-m103: URL: https://vagrantcloud.com/ubuntu/trusty64
==> mongod-m103: Adding box ‘ubuntu/trusty64’ (v20190409.0.0) for provider: virtualbox
mongod-m103: Downloading: https://vagrantcloud.com/ubuntu/boxes/trusty64/versions/20190409.0.0/providers/virtualbox.box
mongod-m103: Download redirected to host: cloud-images.ubuntu.com
mongod-m103:
==> mongod-m103: Successfully added box ‘ubuntu/trusty64’ (v20190409.0.0) for ‘virtualbox’!
==> mongod-m103: Importing base box ‘ubuntu/trusty64’…
==> mongod-m103: Matching MAC address for NAT networking…
==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports…
Vagrant is currently configured to create VirtualBox synced folders with
the SharedFoldersEnableSymlinksCreate option enabled. If the Vagrant
guest is not trusted, you may want to disable this option. For more
information on this option, please refer to the VirtualBox manual:

https://www.virtualbox.org/manual/ch04.html#sharedfolders

This option can be disabled globally with an environment variable:

VAGRANT_DISABLE_VBOXSYMLINKCREATE=1

or on a per folder basis within the Vagrantfile:

config.vm.synced_folder ‘/host/path’, ‘/guest/path’, SharedFoldersEnableSymlinksCreate: false
==> mongod-m103: Vagrant has detected a configuration issue which exposes a
==> mongod-m103: vulnerability with the installed version of VirtualBox. The
==> mongod-m103: current guest is configured to use an E1000 NIC type for a
==> mongod-m103: network adapter which is vulnerable in this version of VirtualBox.
==> mongod-m103: Ensure the guest is trusted to use this configuration or update
==> mongod-m103: the NIC type using one of the methods below:
==> mongod-m103:
==> mongod-m103: https://www.vagrantup.com/docs/virtualbox/configuration.html#default-nic-type
==> mongod-m103: https://www.vagrantup.com/docs/virtualbox/networking.html#virtualbox-nic-type
==> mongod-m103: Clearing any previously set network interfaces…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“hostonlyif”, “create”]

Stderr: 0%…
Progress state: E_INVALIDARG
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Assertion failed: [!aInterfaceName.isEmpty()] at ‘F:\tinderbox\win-5.2\src\VBox\Main\src-server\HostNetworkInterfaceImpl.cpp’ (76) in long __cdecl HostNetworkInterface::init(class com::Bstr,class com::Bstr,class com::Guid,enum __MIDL___MIDL_itf_VirtualBox_0000_0000_0038).
VBoxManage.exe: error: Please contact the product vendor!
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage.exe: error: Context: “enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)” at line 94 of file VBoxManageHostonly.cpp

C:\MongoDB\m103>

I don’t see any thing specific for Windows 10 Home. Here check this thread:

Let me know if it does not help.

Kanika

Hi Kanika,

I am not sure what I did that get it to work but it is working now using an older version of Virtual Box and the newest version of Vagrant.

It’s just a bit annoying that the Window doesn’t stay maximize all the time.

I am glad you got it working! :partying_face:

Din’t understand this right? Maximize as in screen size?

Kanika

Yeah maximize as in the terminal window. It kept on flipping between maximize window and the restore to size thing.The size of the window kept on toggling between the restored window size to the maximum size.
I do however can just use mingw’s ssh :slight_smile:

Hi
i have the same issue but i prefer a better solution and not to download and run some exe from random person on the internet. any idea how this should be solved?
i am using windows

Hi @ykj,

Please check the Handouts in the Lecture: Setting up the Vagrant Environment for your Operating System for detailed instructions on Downloading and Installing VirtualBox/Vagrant and setting up Vagrant Environment.

Note: Try vagrant up --provision instead of vagrant up

If you still see any error, please share the screenshot of the command that you have run with the error message.

Please let me know, if you have any questions.

Thanks,
Sonali