"vagrant provision" command error on macOS

Issue

Cannot provision Vagrant to download data sets, validation scripts, etc…

Command

> vagrant up --provision

Output

Bringing machine 'mongod-m103' up with 'virtualbox' provider...
==> mongod-m103: Running provisioner: shell...
    mongod-m103: Running: /var/folders/mv/ly1p1_w52zl9r2p82d0bdfp40000gn/T/vagrant-shell20200220-4983-16lr6yf
    mongod-m103: + config
    mongod-m103: + sudo su
    mongod-m103: + echo -e never
    mongod-m103: + echo -e never
    mongod-m103: + echo manual
    mongod-m103: + sudo tee /etc/init/mongod.override
    mongod-m103: manual
    mongod-m103: + ip_config
    mongod-m103: ++ ifconfig
    mongod-m103: ++ grep 'inet addr:'
    mongod-m103: ++ tail -1
    mongod-m103: ++ grep -v 127.0.0.1
    mongod-m103: ++ awk '{ print $1}'
    mongod-m103: ++ cut -d: -f2
    mongod-m103: + export CLIENT_IP_ADDR=192.168.103.100
    mongod-m103: + CLIENT_IP_ADDR=192.168.103.100
    mongod-m103: ++ hostname
    mongod-m103: ++ tr '[:upper:]' '[:lower:]'
    mongod-m103: ++ cut -d. -f 1
    mongod-m103: + export CLIENT_NAME=m103
    mongod-m103: + CLIENT_NAME=m103
    mongod-m103: + echo 'Configuring /etc/hosts ...'
    mongod-m103: Configuring /etc/hosts ...
    mongod-m103: + echo '127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 '
    mongod-m103: + echo '::1       localhost localhost.localdomain localhost6 localhost6.localdomain6'
    mongod-m103: + echo 'fe00::0 ip6-localnet'
    mongod-m103: + echo 'ff00::0 ip6-mcastprefix'
    mongod-m103: + echo 'ff02::1 ip6-allnodes'
    mongod-m103: + echo 'ff02::2 ip6-allrouters'
    mongod-m103: + echo 'ff02::3 ip6-allhosts'
    mongod-m103: + echo '192.168.103.100 m103'
    mongod-m103: Install MongoDB Enterprise Repository
    mongod-m103: + update_repo
    mongod-m103: + echo 'Install MongoDB Enterprise Repository'
    mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
    mongod-m103: + echo 'deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse'
    mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
    mongod-m103: + sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
    mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.nFOvmjuFIu --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/ubuntu-advantage-esm-infra-trusty.gpg --keyserver keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
    mongod-m103: gpg: 
    mongod-m103: requesting key A15703C6 from hkp server keyserver.ubuntu.com
    mongod-m103: ?: keyserver.ubuntu.com: Host not found
    mongod-m103: gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out
    mongod-m103: gpg: no valid OpenPGP data found.
    mongod-m103: gpg: Total number processed: 0
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Error

mongod-m103: ?: keyserver.ubuntu.com: Host not found
    mongod-m103: gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out
    mongod-m103: gpg: no valid OpenPGP data found.
    mongod-m103: gpg: Total number processed: 0
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Hi @hashdesk,

Are you connected to any Corporate / VPN network ?

Please make sure that firewall / anti-virus is not blocking the requests.

Thanks,
Shubham Ranjan
Curriculum Services Engineer