Vagrant not in System requirements

Hello. The course system requirements should mention all necessary software, but does not list Vagrant https://university.mongodb.com/courses/M103/about

  • Web Browser: Firefox 39.0+ or Chrome 43+ (Internet Explorer is currently not supported)
  • Operating System: Mac OS X 10.7+ 64-bit, Ubuntu 14.04+ 64-bit, or Windows 8+ (64-bit)
  • MongoDB: 3.6.2+ Enterprise
  • ? Vagrant ?

Good point!

You may add VirtualBox onto that as well as hardware requirements like a CPU with hardware virtualization support and a minumum of 4GB of RAM.

@Kanika, something to consider for the next iteration?

The idea behind not putting Vagrant as a requirement because not having vagrant won’t restrict anyone to learn from the course. It is for their own practice and for all the Labs. There are some students who just want to gather knowledge without worrying about Labs (grades) which requires Vagrant.

Said that we still highly recommend using vagrant during the course! :slight_smile:

Kanika

In that case perhaps you could add a heading under the requirements that states “To perform lab exercises you will also need…”.

That makes sense!! Let me see what I can do.

Kanika

1 Like

Hi Kanika,

I followed the steps you mentioned but it seems there might be something that i’ve missed. When i entered the vagrant up --provision command, it executed some steps and got stuck on “==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…”

Could you please help me on this

Hi @mohd_jawwad_64844,

Can you please share the details of the system/OS you are using?

Meanwhile, please try re-provisioning your vagrant and take a look at the following threads for reference:

Let me know if it helps!

Thanks,
Muskan
Curriculum Support Engineer

Hi Muskaan,

PFB the screenshot knowing the details of the system.

Hi Muskaan,

I restarted the entire process and i am getting a new error now which is as follows:

==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “1e4a0d91-5292-486b-8d74-735842dccc47”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: Not in a hypervisor partition (HVP=0) (VERR_NEM_NOT_AVAILABLE).
VBoxManage.exe: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

Hi @mohd_jawwad_64844,

For this particular error, you need to enable virtualization in the BIOS settings.

The lecture on Troubleshooting Vagrant setup lists the solution for this issue as follows:

1. Enable virtualization in the BIOS.
2. Make sure you have Hyper-V turned off in Windows 10 
   For Windows 10: Press Windows key. 
   Type "Turn Windows features on or off" Deselect the checkbox next to Hyper-V. 
   Select OK. 
   Select Restart now. 

Please let me know if you still face any issues.

Thanks,
Muskan
Curriculum Support Engineer

Hi Muskan,

You mean to say that i deselect the “Windows Hypervisor Platform” from the screenshot attached?
If so, that was already deselected. Could you please let me know.

Thanks,
Mohd Jawwad Hussain.

Hi @mohd_jawwad_64844,

Yes, you are right, hyper-v is already disabled in your system but you need to enable virtualization(vt-x) in the BIOS settings to get rid of the error mentioned by you.

Please look at the following link where all the steps to enable virtualization have been listed:

https://www.tutorialspoint.com/windows10/windows10_virtualization.htm

Thanks,
Muskan
Curriculum Support Engineer