Vagrant installation failed

Hi, it’s not the first time that i use vagrant but i can’t install the file for the m310 project.

Any help please ?

infrastructure: Box ‘centos/7’ could not be found. Attempting to find and install…
infrastructure: Box Provider: virtualbox
infrastructure: Box Version: >= 0
The box ‘centos/7’ could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp’s Vagrant Cloud, please verify you’re logged in via
vagrant login. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: [“https://vagrantcloud.com/centos/7”]
Error: SSL certificate problem: self signed certificate in certificate chain

C:\Users****\Desktop\university\m310-vagrant-env>apt-get autoremove
‘apt-get’ n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

1 Like

Mon frėre, quoi?! :smiley: Why are you running apt on the Windows command line?

URL: [“https://vagrantcloud.com/centos/7”]
Error: SSL certificate problem: self signed certificate in certificate chain

This though, is a problem. But it’s not a problem with you, it’s a security at Vagrant Cloud. I don’t know why, but their certificate is giving problems. An important website like theirs should never use a self-signed cert.

So, the problem is not with you. I would wait a few hours and try again later. Perhaps the guys at Hashicorp are working on something.

EDIT:
I have checked the website just now and their certificate looks to be in order. It is not self-signed, but signed by Let’s Encrypt.

If your system still throws the same error message, then I would ask whether you are currently at the office or somewhere else that is not your home network. Because what you are seeing could be caused by a proxy server which strips open the TLS traffic between your host and VagrantCloud, replacing their certificate with its own self-signed cert. This only happens in corporate environments or situations where someone really wants to see all your network traffic.

I can’t do vagrant ssh due to the error that’s why i tried like a noob to run apt-get autoremove ahaha.

OK thanks, so basically for now i’m stuck, right ?

1 Like

Ah, you were faster than me. Please read my update above your post. It could be important.

I’m at my home network, so your are saying someone is watching my trafic if i understood right ?

I dont know if it’s this, but i ran a month ago, for a udemy tutorial the ssh command for mongodb, so i have a self-signed certificate.

Well it’s fine if YOU have self-signed certificates, but vagrant should never report a self-signed certificate when it tries to download an OS image from VagrantCloud. That would be horrible!

To verify:

  1. You are running vagrant up infrastructure or vagrant up.
  2. You are running this on your host OS. So not inside a VM, but on the OS of your computer.
  3. You are simply connected to your home network.

All of those are correct?

I tried before the vagrant up command, but that gave me the error:

URL: [“https://vagrantcloud.com/centos/7”]
Error: SSL certificate problem: self signed certificate in certificate chain

Yes i run the VM on my windows 10, i’m simply connected to it

That is very, very odd…

What happens when you visit the following URL in your web browser?

https://vagrantcloud.com/centos/7

This should show you the following website. Also, if you inspect the certificate with your browser, it should show a valid cert signed by Let’s Encrypt. Of course the UI will look different in IE or Edge :wink:

1 Like

Could it be an interferance with Kaspersky Lab ?

1 Like

Yes ! I found the problem thank you very much, it was indeed the kaspersky lab antivirus who didnt let the files to load, so i just disabled it for a moment. Thank’s Tess_Sluijter

1 Like

Holy crap! This means that the Kaspersky software is actually nestling between the processes on your computer and the remote server. It is cracking open your TLS traffic and effectively performing a man-in-the-middle, pretending to be the remote server.

On the one hand that’s not unexpected for an Internet security product, but I certainly hope that it’s an advertised feature and not something they don’t tell you.

EDIT:
It is possible to disable this in a Kaspersky setting:

https://forum.kaspersky.com/index.php?/topic/371162-how-to-disable-ssl-interception/

However, this still means that Kaspersky have forced their root certificate into your computer’s trust-store when you installed the product. Again, that is an advertised feature, but in the past this has also caused (big) security problems. For example:

There has also been some research suggesting that this interception brings on more risks.

1 Like

Thank’s for the documentation.

Do you have maybe an alternative to kaspersky ?