Vagrant install failure for Windows 2012 64 bit

Vagrant install failure for Windows 2012 64 bit

Installation was successful but does not work for Vagrant on Windows 2012 Server 64bit as well as (mingw-get-setup.exe) installation did not work

Windows Server 2012 is the server version of Windows 8

You will need to download the setup files for Win 8 (64 bit)

Hi

I did download but the installation does not work

Do you have the setup steps for Windows Server 2012 R2.

Kind Regards

Diogo Fernandes

Or if you can send me the link for the download

I also have an issue with [MinGW Installer (mingw-get-setup.exe)]

As the video says these are to be installed inside the virtual machine. On the host machine the installation works but inside the virtual machine it does not work.

Hi looks like I may be having issues with the port 27017. If you can guide me with this

I have installed vagrant but get this error

:\HashiCorp\Vagrant\bin>vagrant up
Vagrant environment or target machine is required to run this
ommand. Run vagrant init to create a new Vagrant environment. Or,
et an ID of a target machine from vagrant global-status to run
his command on. A final option is to change to a directory with a
agrantfile and to try again.

:\HashiCorp\Vagrant\bin>vagrant global-status
d name provider state directory

here are no active Vagrant environments on this computer! Or,
ou haven’t destroyed and recreated Vagrant environments that were
tarted with an older version of Vagrant.

Hv reached to this point now with vagrant

C:\HashiCorp\Vagrant\bin>vagrant up --provision
Bringing machine ‘default’ up with ‘hyperv’ provider…
==> default: Verifying Hyper-V is enabled…
The Hyper-V cmdlets for PowerShell are not available! Vagrant
requires these to control Hyper-V. Please enable them in the
“Windows Features” control panel and try again.

Hi diogod28,

Thanks for reaching out to us.

Please review all the points mentioned here.

Let me know if you have any issues.

Kanika

HI Kanikasingla

Would like to let you know my scenario.

I have installed Oraclel Virtual box and in Oracle Virtual box I have one vm for windows 2012 R2 and I am trying to do all the labs in the vm is that right?

Installation is successfull but not able to run vagrant up command in the vm. Getting this msg
F:\university\M103\m103-vagrant-env>vagrant up -provision
F:/university/M103/Vagrant/embedded/gems/2.2.2/gems/vagrant-2.2.2/lib/vagrant/plugin/v2/command.rb:62:in parse_options': ambiguous option: -provision (OptionParser::AmbiguousOption) from F:/university/M103/Vagrant/embedded/gems/2.2.2/gems/vagrant-2.2.2/plugins/commands/up/command.rb:54:inexecute’
from F:/university/M103/Vagrant/embedded/gems/2.2.2/gems/vagrant-2.2.2/lib/vagrant/cli.rb:58:in execute' from F:/university/M103/Vagrant/embedded/gems/2.2.2/gems/vagrant-2.2.2/lib/vagrant/environment.rb:291:incli’
from F:/university/M103/Vagrant/embedded/gems/2.2.2/gems/vagrant-2.2.2/bin/vagrant:164:in `’

Regards

Diogo

Vagrant up gives this message

F:\university\M103\m103-vagrant-env>vagrant up
Bringing machine ‘mongod-m103’ up with ‘hyperv’ provider…
==> mongod-m103: Verifying Hyper-V is enabled…
The Hyper-V cmdlets for PowerShell are not available! Vagrant
requires these to control Hyper-V. Please enable them in the
“Windows Features” control panel and try again.

I think I figured out what is the issue

Your instruction on the labs are not clear. Account to you training it is mention all the labs are to be done inside the vm

But the installation should be done on the host machine

such a waste of time