Vagrant Infrastrucure

I connected and copied the files to the shared folder, yet the folder is empty inside vagrant!
When I use up it gives that error on building

Failed to mount folders in Linux guest. This is usually because
the “vboxsf” file system is not available. Please verify that
the guest additions are properly installed in the guest and
can work properly. The command attempted was:
mount -t vboxsf -o uid=id -u vagrant,gid=getent group vagrant | cut -d: -f3 home_vagrant_shared /home/vagrant/shared
mount -t vboxsf -o uid=id -u vagrant,gid=id -g vagrant home_vagrant_shared /home/vagrant/shared
The error output from the last command was:
mount: unknown filesystem type ‘vboxsf’

Hi Hawk_24700,

Be sure you’ve installed vagrant-vbguest plugin. If that’s installed - next I would go through the troubling shooting steps outlined:

https://university.mongodb.com/mercury/M310/2018_October/chapter/Chapter_1_Authentication/lesson/5859a68260b582a61b0ce3cf/tab/5859a68260b582a61b0ce3ce

Hope that helps,

David

I got the same error at first launch, I was running docker than when I quit docker, I was able to use vagrant.

Ok, I tried to install vagrant-vbguest plugin it gave me that error

Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
/usr/lib/ruby/2.3.0/rubygems/specification.rb:949:in all=': undefined methodgroup_by’ for nil:NilClass (NoMethodError)
from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:275:in with_isolated_gem' from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:231:ininternal_install’
from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:102:in install' from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:62:inblock in install_plugin’
from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:72:in install_plugin' from /usr/share/vagrant/plugins/commands/plugin/action/install_gem.rb:37:incall’
from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:34:in call' from /usr/lib/ruby/vendor_ruby/vagrant/action/builder.rb:116:incall’
from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in block in run' from /usr/lib/ruby/vendor_ruby/vagrant/util/busy.rb:19:inbusy’
from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in run' from /usr/share/vagrant/plugins/commands/plugin/command/base.rb:14:inaction’
from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:32:in block in execute' from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:ineach’
from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:in execute' from /usr/share/vagrant/plugins/commands/plugin/command/root.rb:56:inexecute’
from /usr/lib/ruby/vendor_ruby/vagrant/cli.rb:42:in execute' from /usr/lib/ruby/vendor_ruby/vagrant/environment.rb:268:incli’
from /usr/bin/vagrant:173:in `

I managed to install vagrant-vbguest plugin by reinstalling vagrant from the dpkg from here https://www.vagrantup.com/downloads.html rather than the one in ubuntu software center now it is working

Glad you got it working - thanks for sharing your solution

I also had also some troubles, here´s what i did:

  • added the cdrom with the guest additional, which is the code below from here
yum update
yum install dkms gcc make kernel-devel bzip2 binutils patch libgomp glibc-headers glibc-devel kernel-headers
mkdir -p /media/cdrom
mount /dev/sr0 /media/cdrom
sh /media/cdrom/VBoxLinuxAdditions.run
  • then i ran vagrant halt infrastructure && vagrant up infrastructure on my local machine

It did some provisioning, as far as i could see on the console, but after that it worked.
I dont know if i will ran into trouble at some point with this configurations, but for now it doesnt compain.

Thanks for sharing !