[Vagrant] infrastructure VM does not install properly

It seems I am not the first to have this kind of problem but I do not see any answer to the problem in the discussion.

I am on a personal windows 10 lenovo P73.

I installed vagrant in march 2020 and used it on previous mongodb courses without problem. This install included minGW ssh and rsync. I do see them under C:\MinGW\msys\1.0\bin. This path is included in the windows PATH variable. Rsync and ssh do answer when called from cmd prompt.

I installed the vagrant-vbguest plugin without problem. It is listed when I ask for vagrant plugin list.

I corrected the provision-database file since the first attempt to start the database VM failed. It is now up and running (I destroyed then recreated the VM). I can connect to the database VM and it does show a mongo install.

I then tried several times to start the infrastructure VM and it always fails at the SSH connexion attempt and goes in timeout. I destroyed the infra VM and tried several times to start it but it still fails the same way. I rebooted windows, tried with database VM running and stopped (vagrant halt database) but I still have the same problem. Both VM are shown as running in the virtualbox interface but vagrant does not seems to be able to connect to the infrastructure one.

I note that there is a port collision mentioned during the infra start but it is noted as resolved (2222 => 2200). Indeed the ssh connexion that fails (timeout) is made to 127.0.0.1:2200. The port redirection is mentionned correctly in the virtualbox admin interface for network properties of infrastructure VM.


Here’s the error I see in vagrant :

Any idea ?

There are couple of threads on vagrant up infrastructure
Please go through them
Did you try vagrant infrastructure destroy -f (force)
Sometimes it could be version issues or firewall/ports issue
When i took this course long back vagrant up brings up both database and infrastructure
Later some bugs and each one required to start individually after running vbguest plugin step
If nothing works try to download zip file and repeat again
Course instructors can help more on this

Hi,

I spend quite some time reading these threads but could not find a solution. For the vagrant destroy infrastructure it is in the capture above, just before a “vagrant up infrastructure” attempt.

I am beginning to think that the previous instal and use of vagrant for the M103 course did left some traces that interfere with the M310 install.

For example I found that the vagrant global-status was not up-to-date but purging (pruning) the said status did not help for the infrastructure.

I do not know vagrant enough to remove unwanted data from the .vagrant directory/sub-directories under \users<install user>.

Michel

Tried to reinitialize vagrant by dropping the .vragrant directory as per https://www.vagrantup.com/docs/installation/uninstallation

After reinstalling the vagrant-vbguest plugin I tried a vagrant up but same problem !

Please check this link for any version related issues and last update from

Chris_98448
Jan 8
So, I was having the same issue. Looking around on the internet there seems to be a issue with the vagrant centos/7 image and VirtualBox 6.0.8 and above. What I did was:

delete all the VMs out of the virtualbox gui.
delete the files out of m301-vagrant-env and re-downloaded
unistall virtualbox
download virtualbox 6.0.6 and installed
run: vagrant plugin install vagrant-vbguest
run: vagrant up database
run: vagrant up infrastructure
All now works

Cannot get infrastruce vm up. ssh times out

Thank you for pointing this link. :smiley: I’ll try that ASAP and keep you posted.

I guess there is something in the virtualbox that’s left from M103 course…

Hope this will solve the problem.

Hi @Michel_Bonade_37275,

In addition to @Ramachandra_37567’s suggestions, you should also remove the previously set-up VMs using the VirtualBox GUI.

Please feel free to reach out if the issue still persists for you.

Thanks,
Sonali

Hi @Sonali_Mamgain,

I have the similar issue, unable to set-up the vagrant environment in my windows 10 machine for M310 Authentication course.

==> database: Checking for guest additions in VM…
database: The guest additions on this VM do not match the installed version of
database: VirtualBox! In most cases this is fine, but in rare cases it can
database: prevent things such as shared folders from working properly. If you see
database: shared folder errors, please make sure the guest additions within the
database: virtual machine match the version of VirtualBox you have installed on
database: your host and reload your VM.
database:
database: Guest Additions Version: 4.3.40
database: VirtualBox Version: 6.1
==> database: Forcing shutdown of VM…
==> database: Destroying VM and associated drives…

I got blocked on this, need help to fix asap.

Thanks
Nagendra

What does vagrant status show
Is the issue with infrastructure or both?
As per your log above it is database related but this thread is for infrastructure
Did you complete vbguest plugin step?

Show the outpt of

vagrant plugin list

I had the same issue trying to get the infrastructure working,
seems like there is a new vagrant guest version that is not working.
try this
vagrant destroy infrastructure
vagrant plugin uninstall vagrant-vbguest
vagrant plugin install vagrant-vbguest --plugin-version 0.21
vagrant up infrastructure

1 Like