Vagrant Error Not starting virtual box machine

I am getting this error even I install virtual box and vagrant it keep asking provider.
seems like it starting hyperv and in the config file it setup for virtual box .

C:\M103\m103-vagrant-env>vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘hyperv’ provider…
==> mongod-m103: Verifying Hyper-V is enabled…
The Hyper-V cmdlets for PowerShell are not available! Vagrant
requires these to control Hyper-V. Please enable them in the
“Windows Features” control panel and try again.

C:\M103\m103-vagrant-env>vagrant up
Bringing machine ‘mongod-m103’ up with ‘hyperv’ provider…
==> mongod-m103: Verifying Hyper-V is enabled…
The Hyper-V cmdlets for PowerShell are not available! Vagrant
requires these to control Hyper-V. Please enable them in the
“Windows Features” control panel and try again.

further trying to find error by looking vagrantfile;

type vagrantfile
if Vagrant::VERSION < “2.0.0”
$stderr.puts “Must redirect to new repository for old Vagrant versions”
Vagrant::DEFAULT_SERVER_URL.replace(‘https://vagrantcloud.com’)
end

Vagrant.configure(“2”) do |config|
config.vm.box = “ubuntu/trusty64”
config.vm.box_check_update = false
config.vm.synced_folder “shared/”, “/shared”, create: true
config.vm.synced_folder “dataset/”, “/dataset”, create: true

config.vm.define “mongod-m103” do |server|
server.vm.provider “virtualbox” do |vb|
vb.customize [“modifyvm”, :id, “–cpus”, “2”]
vb.name = “mongod-m103”
vb.memory = 2048
end
server.vm.hostname = “m103.mongodb.university”
server.vm.network :private_network, ip: “192.168.103.100”
server.vm.provision :shell, path: “provision-mongod”, args: ENV[‘ARGS’]
end
end

Hi @waqar_54488,

I recently had this same discussion with one of your peers. Please have a look:

Hi @waqar_54488,

Please follow the debugging steps mentioned in the thread shared by @007_jb in post #2.

In addition to that please make sure you are using VirtualBox version 6.0.14.

Thanks,
Shubham Ranjan
Curriculum Support Engineer