Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

Upgrade Problem 3.4.24 to 3.6.18

I’m moving along the upgrade path from 2.6.11 to 4.2.6 of my standalone database and have run into my first problem. When I start 3.6.18 mongod.exe returns right away leaving the following in the log file.

** IMPORTANT: UPGRADE PROBLEM: The data files need to be fully upgraded to version 3.4 before attempting an upgrade to 3.6; see http://dochub.mongodb.org/core/3.6-upgrade-fcv for more details.

I’m not worried about remote hosts, so I don’t see anything at the referenced page that is helping me.

Any idea what I’m missing?

Thanks,
Scott

Hi Scott,

This error message is suggesting that you have probably missed setting the featureCompatibilityVersion (FCV) to “3.4” as the final step of your MongoDB 3.4 upgrade.

The FCV setting controls whether an upgraded deployment is able to persist backwards-incompatible data changes. You must finish all MongoDB 3.4 upgrade steps before starting the upgrade to the next major release series. FCV was added as part of the MongoDB 3.4 release so there is a more deterministic point after which downgrading will become more difficult because of backwards-incompatible features persisted in the data files. You’ll have to set FCV appropriately as the last step for any major version upgrades after the 3.4 release.

The dochub link should redirect to the Upgrade Procedures section of the 3.6 release notes which suggests checking the FCV version via the output of:

db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )

The release notes page is quite long, so it may take a moment to scroll to the relevant section of the page after it loads.

What is the current FCV setting for your deployment? If it is not set to “3.4” please follow the last step in the 3.4 upgrade guide.

Since upgrade steps and caveats may change between major versions, I’d definitely recommend reading the relevant upgrade procedures and compatibility changes for each release to avoid any unexpected challenges.

Regards,
Stennie

I had already set that parameter prior to submitting this plea (though I had missed it earlier). From the 3.4.24 shell:

db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )
{ “featureCompatibilityVersion” : “3.4”, “ok” : 1 }

ARGH!
I have seen the enemy, and it is I!
In an effort to make rollbacks easy, I’ve been copying databases forward as I proceed from version to version. Unfortunately, I failed to copy the 3.4.24 db forward to my 3.6.18 workarea after setting the FCV. Thanks for the reminder!

Sorry for the trouble.
Scott

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.