Update Vagrant?

I am currently using 2.1.5 but it says that 2.2.0 is available. Is it better to use the most current version or stick with what is installed?

It’s almost always better to upgrade your software. In this case, upgrading Vagrant does not change anything about the virtual machine (Ubuntu), or the virtualization software (VirtualBox), nor the MongoDB software. So go right ahead!