Unable to start vagrant

i am using ubuntu 16.04
virtualbox : 6.0
vagrant : 2.2.6

when i run the command

vagrant up

it shows the following error . i cant able to setup vagrant .

There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “0fbc438a-4d90-4c91-8d78-2e7343aa328e”, “–type”, “headless”]

Stderr: VBoxManage: error: The virtual machine ‘m310_database_1574141867097_67700’ has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

i have tried reinstalling both virtualbox and vagrant.still the same.
tried the following command . still the same

sudo /sbin/vboxconfig

can someone help me .

You have two machines to provision so try starting them up one by one by specifying the machine:
vagrant up database --provision
or
vagrant up database

vagrant up infrastructure --provision
or
vagrant up infrastructure

same issue after runing this command

vagrant up database --provision

What about infrastructure?

Hi @gotam,

Please try the following solution:

  • Enable virtualization in the BIOS.
  • Make sure you have Hyper-V turned off in Windows 10 For Windows 10: Press Windows key. Type “Turn Windows features on or off”Deselect checkbox next to Hyper-V. Select OK. Select Restart now.

Kanika

i have checked BIOS

intel virtualization technology is enabled

i am using ubuntu 16.04 .

oh! I am really sorry about this. This issue is fairly common in Windows, so I just jumped to this. Point was to enable virtualisation. But if is already enabled, then have to look more.

Let me find some solution.

Hi @gotam,

Found these solutions online. Solution worked for them is reinstalling vagrant box.

Make sure to delete/remove all the files from previous install and then do the reinstallation.

Kanika

above links didnt help to solve.
I uninstalled virtualbox and various versions of virtualbox [ 5.0,5.1,5.2,6.0 ]
worked fine with 5.2 version. Rest all failed to work.

Working combo
OS : ubuntu 16.04 / centos 7
vagrant : 2.2.6
Virtualbox: 5.2

Probably recent updates for 6.0 might have caused this issue .