Unable to pull with realm-cli

Hi,

I am using the 2.0beta realm-cli and trying to pull the app.

trying this:
realm-cli pull --remote myapp-rqpmy

and I get:
export failed: must specify --remote or run command from inside a Realm app directory

I’ve already logged in. Any idea what’s missing?

Thanks…

Hi @donut, I’ve just tried this with realm-cli version 2.0.0-beta.4.

The only way I’ve found to get that error if the realm-app-id provided doesn’t match an existing Realm app from the project where I created the API key.

Is myapp-rqpmy an existing Realm app in the same project as the API key you used to log into realm-cli?

1 Like