Unable to launch mongod with config file

mongod is not launching. I am doing the “Lab: Configuration File” exercise. Please help.

Make sure your indentation is consistent with 2 spaces.

Make sure you have no white space and to tab after the : of security.

The quotes around enabled might be causing the problem.

Adding up on the previous reply, you need a space before “enabled”

authorization: "enabled"
or
authorization: enabled

From the image, authorization and port are not aligned, so one of those is causing trouble.


I haven’t tried it but the issues may be solved using yaml analyzer :slight_smile:

Add a space before authorization, it needs two spaces not one, that’s why you get that error about security.

Thank you! It worked :slight_smile:

1 Like

Thank you, especially for the yaml anlayzer :slight_smile:

Thank you :slight_smile:

1 Like