Unable to install mongo shell on ubuntu

1st problem>>>
user@user-Aspire-E5-575G:~$ sudo apt-get install -y mongodb-enterprise=4.2.0;
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise : Depends: mongodb-enterprise-server but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

2nd problem>>>
user@user-Aspire-E5-575G:~$ sudo apt-get install -y mongodb-enterprise-server=4.2.0;
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libsensors4 (>= 1:3.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

i also tried combined command.it is as follows:
user@user-Aspire-E5-575G:~$ sudo apt-get install -y mongodb-enterprise=4.2.0 mongodb-enterprise-server=4.2.0 mongodb-enterprise-shell=4.2.0 mongodb-enterprise-mongos=4.2.0 mongodb-enterprise-tools=4.2.0;
Reading package lists… Done
Building dependency tree
Reading state information… Done
mongodb-enterprise-mongos is already the newest version (4.2.0).
mongodb-enterprise-shell is already the newest version (4.2.0).
mongodb-enterprise-tools is already the newest version (4.2.0).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libsensors4 (>= 1:3.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

my pc configuration is
memory:3.7 GiB;
ubuntu version:ubuntu 19.04;
processor:Intel® Core™ i3-6006U CPU @ 2.00GHz × 4 ;
graphics:Intel® HD Graphics 520 (Skylake GT2) / NV117;
gnome:3.32.1;
os type:64-bit;
disk:1.0 TB;

Do help… thanks in advance !!!

Hey @Prasad_35679

Have you been over the installation guide. https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/

There is also a section on troubleshooting?

Hope it helps

1 Like

Hi @Prasad_35679,

If your are still unable to setup mongo shell on your system then please check this post. Please feel free to get back to us if the issue still persists.

Thanks,
Shubham Ranjan
Curriculum Support Engineer