Unable to install mongo DB on Kali Linux

Hallo,
Am James Besigye from Kampala Uganda…
Have struggled to install Mongo to my Kali distro. did successfully install compass but mongo has failed.
anyone managed to install on Kali? did you use the Ubuntu or Debian installs.
please help

Hi @James_93810 in Kampala!

I know nothing of this distro but I came across this link which you could try. And since Kali is a derivation of Debian, perhaps you could get some additional pointers from the official installation instructions for Debian.

Hi,
Thanks @007_jb
The resource was helpful but it only enables installation of community edition. the challenge is installation of enterprise edition…
Thanks for the resource

Hi @James_93810,

I am not sure about this but I think you should try the Debian based package.

Can you please provide some more information on this such as the error message that you are getting and the version of you OS as well ?

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hallo Ranjan,

been searching around the web and found that my challenge is old and was already reported check the issue below. same problem with Debian version. However,

mongo community install is fine, will it affect me or should i proceed with community install??

Besigye@kali:~$ sudo apt-get install -y mongodb-enterprise-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libsensors4 (>= 1:3.0.0) but it is not installable
Depends: libsnmp30 (>= 5.7.3+dfsg-1.8ubuntu3.3~dfsg) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

  • Comments


Permalink

mathew.robinsonMathew Robinson added a comment - May 23 2019 04:55:24 PM GMT+0000 - edited

I have verified this and don’t think we can do anything about it. The 18.04 builds are not guaranteed to run on 19.04.

I started to do some digging and found that we’re linking into libsensors as a dependency of libsnmp (of which we statically link the system version). You can see this from the following compile command (note the -lsensors):

build/cached/third_party/gperftools-2.7/libtcmalloc_minimal.a -Wl,--no-whole-archive build/cached/mongo/util/libdebugger.a -Wl,--whole-archive build/cached/mongo/libboost_assert_shim.a -Wl,--no-whole-archive -Wl,--end-group -lnetsnmpmibs -lsensors -lpci -ldl -lnetsnmpagent -lwrap -lnetsnmp -lcrypto -lm -lldap -llber -lsasl2 -lgssapi_krb5 -lsasl2 -lcurl -lm -lresolv -lcrypto -lssl -lcrypto -ldl -lrt -ldl

These flags come from the net-snmp-config command we run in the enterprise build. Running on an Ubuntu 18.04 host we get:

root@9764228b0c2f:/# net-snmp-config --agent-libs
-Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -L/usr/lib/x86_64-linux-gnu -lnetsnmpmibs -lsensors -lpci -ldl -lnetsnmpagent -lwrap -Wl,-E -lnetsnmp -lcrypto -lm
root@9764228b0c2f:/#

In Ubuntu 19.04 they upgraded to libsensors 5 so the old libsensors4.so is no longer there. If you build enterprise on Ubuntu 19.04 it links to the new libsensors correctly. So the only way for us to fix this would be to start releasing Ubuntu 19.04 packages, which we’re unlikely to do given it’s not an LTS release.

People

  • Assignee:
    mathew.robinson Mathew Robinson
    Reporter:
    james.blackhurst Jim Blackhurst
    Participants:
    Jim Blackhurst, (1)
    Mathew Robinson

  • Votes:
    0 Vote for this issue
    Watchers:
    6 Start watching this issue

Dates

  • Created:
    May 08 2019 11:18:29 AM GMT+0000
    Updated:
    May 23 2019 04:57:31 PM GMT+0000

Am using Kali Linux 5.3.

its a Debian distro however, my error seems to be related with enterprise server having a dependency that is no longer supported.

below is my error
Besigye@kali:~$ sudo apt-get install -y mongodb-enterprise-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libsensors4 (>= 1:3.0.0) but it is not installable
Depends: libsnmp30 (>= 5.7.3+dfsg-1.8ubuntu3.3~dfsg) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.