Unable to Connecting to Your Sandbox Cluster from the mongo Shell

I am using the Version 4.2.9 for the Shell.
I created the new Cluster Sandbox. My connection string is coming out to be -

mongo “mongodb+srv://sandbox.pg0ma.mongodb.net/” --username m001-student

  1. Now I don’t know what the dbname should be. I tried using ‘test’ but I get the same error as -

DNSHostNotFound: Failed to look up service “”:This operation returned because the timeout period expired.
try ‘mongo --help’ for more information

Please help

Your internet provider uses an old DNS server that does not support seed list DNS request.

Try using google’s 8.8.8.8 and 8.8.4.4 public DNS servers.

ok this worked. I did not know about the DNS. Thanks for the help.
Any idea on why am I not getting the DB name automatically whereas most of the screenshots listed on the tutorial as well as here in the discussion forum has ‘test’ as the database name.
Just curious If I made a mistake somewhere.

Thanks again for helping out Steevej. :smiley:

no mistake. it is a habit to put test so that when you connect you always lend in a safe space.

1 Like