Unable to connect to MongoDB Atlas using MongoDB Compass

getaddrinfo ENOTFOUND cluster0-shard-00-00-jxeqq-mongodb.net cluster0-shard-00-00-jxeqq-mongodb.net:27017

This is the error message i am getting when attempting to connect

Hi @Anthony_Mulweye,

Are you able to ping the cluster ?

ping cluster0-shard-00-00-jxeqq.mongodb.net

And also please make sure the port 27017 is not blocked by clicking http://portquiz.net:27017.

If the test fails then please try to disable your firewall/anti-virus if it’s active. Additionally, you can also try to connect from some other network such as your home network.

Hope it helps!

Thanks,
Shubham Ranjan
Curriculum Support Engineer

HI @Shubham_Ranjan,
I still get the error message even after trying the ping…
I have been able to ping and telnet the cluster using windows powershell, the portquiz also shows port 27017 is not blocked cause i can reach it.
i have also disabled windows defender since its the firewall and protection i have but the error message still shows.
I am not sure what could be the issue now?

@Anthony_Mulweye Let’s see a full screenshot of:

  • The ping command and results
  • Compass screen. Capture the error message and your setup in one screen. Don’t worry if “Favourite Name” is not captured.

Hi @Anthony_Mulweye,

In addition to @007_jb,

Please share the following details :

  1. Version of the Compass that you are using
  2. Version of your Windows operating system

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi
@007_jb,
@Shubham_Ranjan,

I’m using Windows 10 64-bit and the Compass version is: 1.19.12 Stable, i downloaded from the MongoDB download center.

The screenshots are:

ping

I’m still stuck. Help

In PowerShell you’ve got the hostname right but in Compass it’s wrong.
It should be jxeqq.mongodb instead of jxeqq-mongodb. Can you see the typo?

@007_jb
Thanks so much for correcting me. I’ve found my way.
I hope you continue helping me through this journey as i dig into Mongo.

Hi @007_jb, good catch :slight_smile:

Hi @Anthony_Mulweye,

I’m glad your issue got resolved, if you have any other query please feel free to get back to us.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Support Engineer