Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

Trouble importing external dependencies

So I tried following this guide to install and import external dependencies via the CLI.

So what I did is:

  • Creating a new package file in the functions folder using “npm init
  • Added my dependency using “npm i the-package-i-wanted
  • Created a tar using “tar -czf node_modules.tar.gz node_modules/
  • Ran the import using “stitch-cli import --include-dependencies

This resulted in the following error:
found more than one node_modules archive in the '<MY-DIR>' directory

So naturally I tried deleting either the node_modules folder and later the archive, but both resulted in this error:
exec: "transpiler": executable file not found in %PATH%

So at this point I gave up and just uploaded the tar to the UI which worked.
However, I’d love to get this to work in my CI/CD workflow.

Any ideas what causes this error and how I can get around this?