Tons of "Attempting to kill operation" messages in log

I am running a sharded setup. I have two shards replica set so far. Shard1 (PSA) contains most data and is usually very busy. I noticed that there were tons of “Attempting to kill operation” in the logs. It resulted in 20-30GB of log file a day. I am pretty sure we don’t issue any opKill commands. We do a lot of upserts. The messages would go away if we shut down the secondary. As soon as the secondary syncs up, the messages show up again. The messages are printing a few hundred times per second.

Is it an issue? How can we turn off the messages?

One of the examples:
{"t":{"$date":"2021-02-07T10:44:39.035-05:00"},"s":"I", "c":"COMMAND", "id":4615602, "ctx":"conn59830","msg":"Attempting to kill operation","attr":{"operationKey":{"uuid":{"$uuid":"3bc054fe-e267-4290-8572-7e4052399011"}}}}

1 Like