This lab is worded so confusing

@Shubham_Ranjan
Use mongoimport to import the data in /dataset/products.json:

  • import this dataset onto m103.products
  • use mongos as the target for mongoimport - you can find the configuration details for this process in mongos.conf
  • authenticate to mongos as m103-admin (with password m103-pass)

I DO NOT GET HOW IM USING MONGOS AND MOMGOIMPORT? I have spend the past hours looking for help and doing everything but I am more confused than I started.

no one is going to help? @Shubham_Ranjan

I still cant import the m103 data base and no one cares to help im going to post this on social media so people can see how helpful anyone from this school answers, not just people who are volunteering

I used this:
mongoimport --port 26000 -u “m103-admin” -p “m103-pass” --authenticationDatabase “admin” --db m103 --collection products

You are missing the file option in your mongoimport

When you want to import from a dump/file you have to mention that in yor command

1 Like

Hi @paul_rosero,

Please note that the MongoDB staffs are only available from 4:30AM - 12:30PM EST time Monday-Friday.

I hope you found @Ramachandra_37567’s response helpful. Let us know if you are still facing any issue

im on eastern time so that basically does not help me since im sleeping the majority of the time, the volunteers do help but its not consistent, because they have things they need to do, meanwhile you are staff members that should be here to help because you get paid to do it. Unfortunate that its geared to help the westcoast since over there is where all the big tech companies are lol.


I have been reading that you should have 5,000 something instead of 9966. not sure if im in the right direction or not.
I used
mongoimport --port 26000 -u “m103-admin” -p “m103-pass” --authenticationDatabase “admin” --db m103 --collection products --file /dataset/products.json
mongo --port 26000 -u “m103-admin” -p “m103-pass” --authenticationDatabase “admin”