The version of powershell currently installed on this host is less than the required minimum version

Hi All,
I’m getting issue while executing vagrant up. I’m inside m103 vagrant env(“E:\MongoDB\m103\m103-vagrant-env>vagrant up”)

Stacktrace : The version of powershell currently installed on this host is less than
the required minimum version. Please upgrade the installed version of
powershell to the minimum required version and run the command again.

Installed version: N/A
Minimum required version: 3.

Need assistance.

Thank you

If Powershell is giving you problems, you may want to install Git Bash for Windows;

https://gitforwindows.org

This will give you the chance to use NIX commands.

Is that going to help Vagrant?! Apparently the Windows version of Vagrant relies upon Powershell…

@Gaurav_40670 which operating system are you running on your computer? And which specific version?

EDIT:
According to that website:

Git BASH
Git for Windows provides a BASH emulation used to run Git from the command line. *NIX users should feel right at home, as the BASH emulation behaves just like the “git” command in LINUX and UNIX environments.

So it’s not even a full Bash, it’s an emulation of parts of it to make Git work.

It could very much be down to my lack of exposure to Vagrant, but I fail to see how this would help Gaurav.

I use Windows laptop running Windows 10. I do web development and have basically replaced my Powershell/CMD with Git Bash for all development work.

I have also integrated it into Visual Studio Code and run all kinds of NIX commands when I am doing frontend or backend development work.

I’ve been using Git Bash for all my MongoDB courses and it works seamlessly in Vagrant so I don’t see how you should have any problems

1 Like

Alright, so it’s a fuller Bash implementation than I had expected. That’s pretty neat. Thank you for providing more details.

Of course, if the OP can get by simply by upgrading Powershell that seems preferable to me. We’ll see how OP responds later on.

And thank you, too, @Tess_Sluijter

You are very active and blessing to the community with your responses.

:+1:

2 Likes

Can’t agree more!

Thanks @Tess_Sluijter for helping us out! We at MongoDB really appreciate your time and effort.

Keep Learning, Kanika

1 Like

Hi,

Sorry for delay in response, I am running windows 10 64bit pro version.
I have tried the vagrant up second time it worked.
I’ve no idea what was issue for first run.

anyways
Thanks alot

Hi,

I’ve been troubles with power shell because I’m using a portatil running W7SP1 Home whe i execute the command

Principal@Portatil-W7 MINGW64 /d/m103/m103-vagrant-env
$ vagrant up --provision
Vagrant failed to initialize at a very early stage:

Failed to locate the powershell executable on the available PATH. Please
ensure powershell is installed and available on the local PATH, then
run the command again.

vagrant up --provider

Vagrant failed to initialize at a very early stage:

The version of powershell currently installed on this host is less than
the required minimum version. Please upgrade the installed version of
powershell to the minimum required version and run the command again.

Installed version: 2

Minimum required version: 3

Then I installed Git Bash for Windows; but now the trouble is:

/d/m103/m103-vagrant-env
$ vagrant up --provision
Vagrant failed to initialize at a very early stage:

Failed to locate the powershell executable on the available PATH. Please
ensure powershell is installed and available on the local PATH, then
run the command again.

Could you help me please!!

Hi @Sonia_07035,

Please check the following links for this issue:

I hope it helps!!

Please let me know, if you have any questions.

Thanks,
Sonali