Supported Function Dependencies - firebase-admin npm

Hi, I was wondering if “firebase-admin”: “9.4.2” npm dependency is supported in Mongodb Realm functions? I tried uploading the archive file for it that I created as explained in the help files and kept getting the attached error.