"startvm" error when vagrant up

Hi Kanika,

I see the solution your provided in another thread. I get the same error. Below are my config details.

  1. My OS is Windows 10
  2. Installed OracleWMware
  3. Installed Ubuntu 18.04 in the VMWare
  4. Installed OracleVMWare and Vagrant in Ubuntu 18.04
  5. When issued “vagrant up” I get the same

Could you please help me on this

Thanks,
Mahendiran

I see the solution your provided in another thread. I get the same error.

What solution in what thread?
What error?

  1. When issued “vagrant up” I get the same

The same what? mystery error I assume?

No one can help you with the provided details

I am also facing error towards the end vagrant up. I am running Windows 7 SP1.
image

When I try to start VM image (mongod-m103) from Virtual box, I get following;
Failed to open a session for the virtual machine mongod-m103 .

VT-x is not available (VERR_VMX_NO_VMX).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Hi Harish,

Have you taken a look at this post here.

Let me know if it does not work for you!

Kanika

No as stderr is blank for me. I am on windows7 so I think only need to check BIOS for virtualization.
I will check this and update shortly.

Then please check here as well.

And many pinned Topics.

Let me know what works for you!

Kanika

There is no virtualization option available in BIOS for me.

Hi Kanika,

There is no Virtualization option in BIOS for me.

Any suggestion how to fix the error in such case.

Thanks,

Harish

Hi Kanika,

Any suggestion? I am stuck and cannot proceed with training.

Thanks,

Harish

Hi Harish_20733,

To help you out, I need more information:

  • By any chance are you running on 32-bit machine?
  • Check this to how to enable BIOS on your machine, I googled these out for you. If these don’t work, just google it and I am sure you will find the right way to set BIOS settings:

Use the f12 key, security, virtualization to make sure that it is enabled. If it doesn’t say VT-x that is ok, it should say VT-d or the like.

When your PC is just starting up you should press DEL (or something) to get to the BIOS settings. There you’ll find an option to enable VT-technology (or something).

Also, look at the errors in detail using debug mode while doing vagrant up:

vagrant up --debug

Check for the main error here. If you need help, then share it with me.

Kanika

Hi Kanika,
It is 64 bit.

When I do debug what will be location of file?

Thanks,

Harish

Hi Harish_20733,

I am sorry for not being clear enough!

You should be in your m103-vagrant-env directory And you have to run :slight_smile:

     vagrant up --debug

This command will show you the debug messages in your console only just like you are seeing when you do vagrant up.

Let me know if you cannot understand the errors shown in debug mode.

Kanika

Thanks Kanika. I will do it shortly.
In worse case scenario, what is alternate option available?

Hi Harish_20733,

You can continue with the lectures.
But I am afraid to say that for graded lessons, you need vagrant up and running.

Kanika

Hello!

I’m doing this course now in February '19 and I was having this same issue. I found the post by Kanika instructing to turn on virtualization in BIOS but I was unable to do this. Apparently, it is not possible to access BIOS in Win8 or Win10 by pressing any button during reboot because the system uses some sort of fast start-up. Instead, you need to go to the settings and in the Recovery section, perform an Advanced restart, which will give an option to access the settings before booting up the OS. Then you have to navigate a few menus to find the settings but unfortunately the menu where virtualization options are supposed to be (UEFI Firmware Settings, according to Laptop Mag and ASUS support) was not available for me :frowning:

BUT running vagrant up --debug instead of vagrant up --provision seems to have fixed the issue for me. :+1:

1 Like