Someone plese help... vagrant handsout not working / not even beeing able to connect to server

Vagrant up – provision
As indicated on the video it’s not installing the dependancies in fact it’s asking for 3rd party system

PS C:\users\jahzw> cd m042
PS C:\users\jahzw\m042> cd m042-vagrant-env
PS C:\users\jahzw\m042\m042-vagrant-env> vagrant up --provision
No usable default provider could be found for your system.

Vagrant relies on interactions with 3rd party systems, known as
“providers”, to provide Vagrant with resources to run development
environments. Examples are VirtualBox, VMware, Hyper-V.

The easiest solution to this message is to install VirtualBox, which
is available for free on all major platforms.

If you believe you already have a provider available, make sure it
is properly installed and configured. You can see more details about
why a particular provider isn’t working by forcing usage with
vagrant up --provider=PROVIDER, which should give you a more specific
error message for that particular provider.
PS C:\users\jahzw\m042\m042-vagrant-env>

I did install dependencies on my windows 10 system following lecture notes guidance but I got also an error that so far I have no received any suggestion or solution

I’m completely stuck and not even beeing able to start… any help please!!!

If I remember correctly, the instructions indicate that you have to install VirtualBox first.

Thanks Steevej … did you read my two final paragraphs

"I did install dependencies on my windows 10 system following lecture notes guidance but I got also an error and so far I have no received any suggestion or solution

I’m completely stuck and not even beeing able to start… any help please!!!"

What he said is that you have to install dependencies in case you want to work in localhost…

He said … "Using the virtual machine for this course, called m042-vagrant-env, we can download and provision an environment that already contains the necessary dependencies for this course as well as any handout files.

In this case, we would call the VM the guest machine."

Maybe I’m lost in translation

You got the error

Which seems to indicate that you did not do one of the step. So please do as the error suggest and install virtualbox.

Hi SteeveJ

Thanks for all your help

I did install again the
VirtualBox
MinGW
rsync and ssh
“Environment Variables…” (for user and system)
Vagrant

Then run the vagrant up and I have the same mistake I reported (link):

PS C:\users\jahzw\m042> cd m042-vagrant-env
PS C:\users\jahzw\m042\m042-vagrant-env> vagrant up
Bringing machine ‘mongodb-m042’ up with ‘virtualbox’ provider…
==> mongodb-m042: Importing base box ‘centos/7’…
==> mongodb-m042: Matching MAC address for NAT networking…
==> mongodb-m042: Checking if box ‘centos/7’ version ‘1905.1’ is up to date…
A VirtualBox machine with the name ‘mongodb-m042’ already exists.
Please use another name or delete the machine with the existing
name, and try again.
PS C:\users\jahzw\m042\m042-vagrant-env>

So I’m back to the same problem :cry::cry::cry:

You do not have the same problem at all.

Before you could not create the vagrant machine because VirtualBox was not installed.

Now, it looks like your virtual machine is already started. From the same directory, try vagrant ssh to log on the VM. You may use the vagrant status command described in https://www.vagrantup.com/docs/cli/status.html to see the status of the VMs.

Hi SteeveJ

PS C:\users\jahzw\m042> cd m042-vagrant-env
PS C:\users\jahzw\m042\m042-vagrant-env> vagrant ssh
VM must be running to open SSH connection. Run vagrant up
to start the virtual machine.
PS C:\users\jahzw\m042\m042-vagrant-env> vagrant up
Bringing machine ‘mongodb-m042’ up with ‘virtualbox’ provider…
==> mongodb-m042: Checking if box ‘centos/7’ version ‘1905.1’ is up to date…
A VirtualBox machine with the name ‘mongodb-m042’ already exists.
Please use another name or delete the machine with the existing
name, and try again.
PS C:\users\jahzw\m042\m042-vagrant-env> vagrant status
Current machine states:

mongodb-m042 poweroff (virtualbox)

The VM is powered off. To restart the VM, simply run vagrant up
PS C:\users\jahzw\m042\m042-vagrant-env>

I open the VM and when I try to start the mongodb-m042 I got the following error:

So I found on youtube how to fix it

Then a new error shows up…
C:\users\jahzw\m042\m042-vagrant-env\shared

Does not exists so I created it

Now I am able to start the mongodb-m042 VM from the VirtualBOx

But on prompt still geting same mistake

PS C:\users\jahzw\m042\m042-vagrant-env> vagrant up
Bringing machine ‘mongodb-m042’ up with ‘virtualbox’ provider…
==> mongodb-m042: Checking if box ‘centos/7’ version ‘1905.1’ is up to date…
A VirtualBox machine with the name ‘mongodb-m042’ already exists.
Please use another name or delete the machine with the existing
name, and try again.
PS C:\users\jahzw\m042\m042-vagrant-env>

someone seems to had found the solution

I wrote to this person as I do not comprehen it but so far I had not received a replay

Honestly… I do not know what else to do

Please check this link
It may help to delete old VMs

Trouble using Vagrant

Thanks SteeveJ and Ramachandra

I finally got it working when I was about to quit
One thing is that vagrant ssh shows more things on prompt than video instructions … I think this must be OK as with the time things had been added

PS C:\users\jahzw\m042\m042-vagrant-env> vagrant ssh
Last login: Wed Sep 25 14:07:06 2019 from 10.0.2.2
[vagrant@m042 ~]$ ll

total 20
drwxr-xr-x. 2 root root 61 Sep 25 14:05 certs
-rw-------. 1 vagrant vagrant 5970 Sep 25 14:31 mongod.log
-rw-------. 1 vagrant vagrant 10307 Sep 25 14:14 mongod.log.2019-09-25T14-24-04
drwxrwxrwx. 1 vagrant vagrant 0 Sep 25 01:48 shared
[vagrant@m042 ~]$

Thanks very much guys I could’t belive I finally got it working

I finished all chapters and I am stuck at last homework result and course does not progress to end. Looks like a bug. What needs to be done to show completion of my course.

Hi,

I got the same error as Jose_20145 with VirtualBox 6.1. Maybe good to mention in this course that the latest VirtualBox version is not supported? See below:

~\m042\m042-vagrant-env>vagrant up --provider=virtualbox
The provider ‘virtualbox’ that was requested to back the machine
‘mongodb-m042’ is reporting that it isn’t usable on this system. The
reason is shown below:

Vagrant has detected that you have a version of VirtualBox installed
that is not supported by this version of Vagrant. Please install one of
the supported versions listed below to use Vagrant:

4.0, 4.1, 4.2, 4.3, 5.0, 5.1, 5.2, 6.0

Thanks @tamsl for notifying this. We will make sure to update it in the curriculum.

Kanika