Shell and server version do not match

As Version 4.0.6 of shell was having issues at installation so I installed 3.4.19, but when I was connecting shell to Cluster, received error : shell and server version do not match", Can somebody? and comments !!

If you had used the forum search and looked for this message you would have found out that this is not an error, but an informational warning and that the shell will work just fine.