Server Timeout in Atlas connection

Hi

I’m checking the [Ticket: Create/Update Comments] and I got the following error message after execute the command pytest -m create_update_comments:

pymongo.errors.ServerSelectionTimeoutError: your_testing_db_uri

During the previous tickets samples I didn’t get that message, it’s the first time. What may be happening with the connection??

Hi @fbermeo1982,

Please share your .ini file contents. Make sure you have good connection and not working from office network or firewall is still off.

Kanika

Hi @Kanika.

All tickets’ challenges (including this), I have been working from my home

My .ini file.

My Windows Firewall is disabled.

And as I sai, after execute the command pytest -v -m create_update_comments in Anaconda prompt, I got the following message:

Please change the MFLIX_DB_URI in .ini file under [TEST] argument:
In place of your_testing_db_uri, please put the same srv connection string.

Kanika

Hi @Kanika

Now, I already passed all test for [Create/Update Comments] challenge.

imagen

But after execute run.py from prompt and click on the corresponding [Create/Update Comments] section…

imagen

I got the following message:

pymongo.errors.ServerSelectionTimeoutError: your_production_db_uri:27017: [Errno 11001] getaddrinfo failed

imagen

Please re-check your connection string in .ini file and your network is stable and your firewall is off.

Kanika