Run jupyter notebooks in Ubuntu 18.04

If you, like me, have got this error running jupyter notebooks in Ubuntu 18.04:

ModuleNotFoundError: No module named 'prompt_toolkit.formatted_text'

Try this:

pip install "ipython==6.5.0"

It’s because a new release of iPython was released one month ago and it needs a newest version of prompt_toolkit module while Jupyter needs an older one. So just install the previous version of iPython (6.5.0) and everything will works fine.

3 Likes

Thanks for this nuggest @giovannireisnunes!