Replica creation - One of the server is not healthy/ reachable

in the Lab: Deploy a Replica Set
All test cases passed, except one. Which says server “127.0.0.1:27001” not reachable.
Please help.

m103-repl:PRIMARY> rs.status()
{
“set” : “m103-repl”,
“date” : ISODate(“2021-01-06T00:00:28.840Z”),
“myState” : 1,
“term” : NumberLong(1),
“syncingTo” : “”,
“syncSourceHost” : “”,
“syncSourceId” : -1,
“heartbeatIntervalMillis” : NumberLong(2000),
“optimes” : {
“lastCommittedOpTime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“readConcernMajorityOpTime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“appliedOpTime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“durableOpTime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
}
},
“lastStableCheckpointTimestamp” : Timestamp(1609891228, 1),
“members” : [
{
“_id” : 0,
“name” : “localhost:27002”,
“health” : 1,
“state” : 1,
“stateStr” : “PRIMARY”,
“uptime” : 3654,
“optime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“optimeDate” : ISODate(“2021-01-06T00:00:28Z”),
“syncingTo” : “”,
“syncSourceHost” : “”,
“syncSourceId” : -1,
“infoMessage” : “”,
“electionTime” : Timestamp(1609887686, 2),
“electionDate” : ISODate(“2021-01-05T23:01:26Z”),
“configVersion” : 3,
“self” : true,
“lastHeartbeatMessage” : “”
},
{
“_id” : 1,
“name” : “127.0.0.1:27003”,
“health” : 1,
“state” : 2,
“stateStr” : “SECONDARY”,
“uptime” : 3301,
“optime” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“optimeDurable” : {
“ts” : Timestamp(1609891228, 1),
“t” : NumberLong(1)
},
“optimeDate” : ISODate(“2021-01-06T00:00:28Z”),
“optimeDurableDate” : ISODate(“2021-01-06T00:00:28Z”),
“lastHeartbeat” : ISODate(“2021-01-06T00:00:28.796Z”),
“lastHeartbeatRecv” : ISODate(“2021-01-06T00:00:27.523Z”),
“pingMs” : NumberLong(0),
“lastHeartbeatMessage” : “”,
“syncingTo” : “localhost:27002”,
“syncSourceHost” : “localhost:27002”,
“syncSourceId” : 0,
“infoMessage” : “”,
“configVersion” : 3
},
{
“_id” : 2,
“name” : “127.0.0.1:27001”,
“health” : 0,
“state” : 8,
“stateStr” : “(not reachable/healthy)”,
“uptime” : 0,
“optime” : {
“ts” : Timestamp(0, 0),
“t” : NumberLong(-1)
},
“optimeDurable” : {
“ts” : Timestamp(0, 0),
“t” : NumberLong(-1)
},
“optimeDate” : ISODate(“1970-01-01T00:00:00Z”),
“optimeDurableDate” : ISODate(“1970-01-01T00:00:00Z”),
“lastHeartbeat” : ISODate(“2021-01-06T00:00:27.622Z”),
“lastHeartbeatRecv” : ISODate(“1970-01-01T00:00:00Z”),
“pingMs” : NumberLong(0),
“lastHeartbeatMessage” : “not running with --replSet”,
“syncingTo” : “”,
“syncSourceHost” : “”,
“syncSourceId” : -1,
“infoMessage” : “”,
“configVersion” : -1
}
],
“ok” : 1,
“operationTime” : Timestamp(1609891228, 1),
“$clusterTime” : {
“clusterTime” : Timestamp(1609891228, 1),
“signature” : {
“hash” : BinData(0,“fM2WzNAZYG5cY/k/1P6oCm82MWI=”),
“keyId” : NumberLong(“6914414965898084353”)
}
}
}

Please check your config file or command line command if any param is missed for this particular node

1 Like