Redirect statement for those with old Vagrant versions

when vagrant up is executed, I get the following statement “Must redirect to new repository for old Vagrant versions” .

Note, I’m using Windows 7 service pack 1. As such uninstalled Vagrant 2.2 for Vagrant 1.96 per directive 1.

What is the redirect that I should use?

Hi Idongesit_24984,

That is an output statement from the Vagrant file. When you run vagrant up if your vagrant version is < 2.0.0 then a DEFAULT_Server_URL parameter gets set.

Then the vagrant process should continue to configure your virtual machine - download the base images and then provision the VMs. If this is the initial vagrant up this may take some time - depending on network, internet, etc.

Is anything happening any other messages/error - after the "Must redirect …" ?

David

if Vagrant::VERSION < “2.0.0”
$stderr.puts “Must redirect to new repository for old Vagrant versions”
Vagrant::DEFAULT_SERVER_URL.replace(‘https://vagrantcloud.com’)
end

1 Like

How much time, is “some time”? On Windows my vagrant process does not seem to be taking any CPU.

C:\Windows\system32>vagrant --version
Vagrant 1.9.6

As David suggested, it depends.

My Internet connection is >100Mbit downstream, with a good in-house network. Downloading the relevant image was fast and the first time I ran “vagrant up” it took about five minutes to get everything up and running.

The question for your situation would be: what’s the Vagrant log showing you? Any errors?

Hours. Had to force close. Could not proceef

Yikes, that’s pretty awful.

So… That leaves the question of your situation: what kind of environment are you working with? How’s your Internet connection and your in-house connection? What would SpeedTest tell you about your bandwidth?

And as I said: if you ran it again, what errors does Vagrant throw at you?

This was done at work with strong bandwidth so that was not the problem. Since it never came out I did not run vagrant. Will try again on Monday.

Right, sorry, I was confusing you with @Bill_89515. Good luck with your download! I hope it works this time.

It downloaded fine. Please reread my original complaint and address directly. I feel like you have not answered my question or given me directions on what to do next

Hi Idongesit_24984,

I’m sorry I have not been able to help.

You asked:

What is the redirect that I should use?

I tried to addressed the particular message and were it was coming from and I asked for any additional details ? It is just a log message and does not require any specific action on your part - vagrant should proceed to download vm images and provision those.

So this is what I understand so far.

  • Windows 7 Host
  • Vagrant 1.9.6
  • vagrant up hangs - No errors when you execute vagrant up

A couple of questions and some suggestions

When you say it downloads fine - what specifically downloads fine ?

What version of Virtual Box are you running ? ( I might suggest version 5.0.28 )

What have you tried so far ? ( Have you tried just rerunning vagrant up ?)

vagrant up --debug ?

Some other things to check - Make sure you have virtualization enabled on you host machine - this is a bios setting. If you’re are doing this at work make sure you’re not behind a firewall ?

Hope this helps,

David

1 Like

To close the loop, I switch to a newer Windows 10 laptop. Vagrant was installed successfully and the VMs started properly via ‘vagrant up’.

1 Like

I went back and installed the most up to date vagrant as opposed to 1.9.x version

Had to update the powershell as Windows 7 had powershell 2 and it needs powershell 3 as minimum. It seems the upgrade of the powershell was what was needed. I would suggest that the instruction to use the older version of vagrant be removed as it was not necessary. Also, a link to upgrade powershell may need to be added.

Will be late on the assignments for this first lesson but will get caught up.

Thanks for checking back in with me.

Idongesit

1 Like

Hi Idongesit_24984,

Glad you stuck with it and got it working. Ordinarily this course is 3 weeks but Week 1 and Week 2 have been extended a week each for this session.

Best,

David

I was wondering about that! :smiley: I guess it’s because of holidays and such? I have to admit that the extra time has come in very handy for me! Between a course last week and doing a presentation this week I’ve not had much time.