Realm Swift - iOS 14 issue - there's no crash, but saved info in database is not available

Hello there,

We work on an app released in store and after updating their iOS version to > 14, users started to complain about info not being populated from database. The issue goes away for awhile if they reinstall the app, but after using it for a few minutes it happens again.

There’s no crash, there’s no error, it’s like there’s nothing saved in the database. We could reproduce the issue only on the store version, if we attach the debugger it never happens and we were able to see that the information is still in the database.

The database uses encryption as documented here.

We already updated realm to the latest version (5.4.7).

We checked this issue https://github.com/realm/realm-cocoa/issues/6671 but it’s not the case for us, we don’t have a shared app group container.

Does this happen to anyone else?

Thanks,
Magda

@Magda_Miu Feel free to open an issue on the realm-cocoa repo and I will make sure the team takes a look

@Ian_Ward we already opened it: https://github.com/realm/realm-cocoa/issues/6843 Please could you help us? Thank you for you guidance.

@Ian_Ward have you talked with the team assigned to the realm-cocoa repo? Please do you have any updates for us?

Yes we took a look but there isn’t any information in there for us to go on. What kind of troubleshooting steps have you taken? Like does the realm file actually exist? Seeing the logs of the app would help - you may need to add extensive logging yourself to the app to figure out what is going on.