README: Setting Up mflix

when i run the server (python run.py) i can’t open MFlix application at http://localhost:5000/.
and when i Running the Unit Tests in the pycharm he show me this:

C:\Users\itama\PycharmProjects\pythonProject\mflix-python>python run.py
Traceback (most recent call last):
  File "run.py", line 1, in <module>
    from mflix.factory import create_app
  File "C:\Users\itama\PycharmProjects\pythonProject\mflix-python\mflix\factory.py", line 12, in <module>
    from mflix.api.movies import movies_api_v1
  File "C:\Users\itama\PycharmProjects\pythonProject\mflix-python\mflix\api\movies.py", line 7, in <module>
    from flask_jwt_extended import (
ImportError: cannot import name 'get_jwt_claims' from 'flask_jwt_extended' (C:\Users\itama\anaconda3\lib\site-packages\flask_jwt_extended\__init__.py)
C:\Users\itama\PycharmProjects\pythonProject\mflix-python>pytest -m LAB_UNIT_TEST_NAME
ImportError while loading conftest 'C:\Users\itama\PycharmProjects\pythonProject\mflix-python\tests\conftest.py'.
tests\conftest.py:2: in <module>
    from mflix.factory import create_app
mflix\factory.py:12: in <module>
    from mflix.api.movies import movies_api_v1
mflix\api\movies.py:7: in <module>
    from flask_jwt_extended import (
E   ImportError: cannot import name 'get_jwt_claims' from 'flask_jwt_extended' (C:\Users\itama\anaconda3\lib\site-packages\flask_jwt_extended\__init__.py)
C:\Users\itama\PycharmProjects\pythonProject\mflix-python>pytest -m connection
ImportError while loading conftest 'C:\Users\itama\PycharmProjects\pythonProject\mflix-python\tests\conftest.py'.
tests\conftest.py:2: in <module>
    from mflix.factory import create_app
mflix\factory.py:12: in <module>
    from mflix.api.movies import movies_api_v1
mflix\api\movies.py:7: in <module>
    from flask_jwt_extended import (
E   ImportError: cannot import name 'get_jwt_claims' from 'flask_jwt_extended' (C:\Users\itama\anaconda3\lib\site-packages\flask_jwt_extended\__init__.py)

From your prompt, it looks like you have not activated the mflix virtual env.

Hi @itamar_comidi

Did @steevej suggestion to activate your virtual environment help resolve these errors? Are you able to complete the setup of your environment for M220?

Kindest regards,
Eoin