Problem Solving for Major Incompatabilities

Tip 0: Nothing working at all? run.py not working?
pip install -r requirements.txt

Tip 1: If your unit tests are failing for
_pytest.warning_types.RemovedInPytest4Warning: getfuncargvalue is deprecated, use getfixturevalue

Solution 1:
pip install pytest==3.1

Tip 2: If you are encountering assertion errors in projection.
Remove the .limit(1) command on the end of the function. It shouldn’t be there even though the comment implies that you should leave it. It’s only there for the start. Just delete it.

1 Like

Tip 2 does not help unfortunately. Anyways, thanks!