Problem - Installing Vagrant for m310

My OS is windows 10 home, Vagrant version is 2.2.6 and virtual box is 6.0.14.
vagrant plugin install vagrant-vbguest
vagrant up
Note: After the above 2 comands, i get the below error. Please help me resolve it.

Bringing machine ‘database’ up with ‘virtualbox’ provider…
Bringing machine ‘infrastructure’ up with ‘virtualbox’ provider…
==> database: Importing base box ‘ubuntu/trusty64’…
==> database: Matching MAC address for NAT networking…
==> database: Checking if box ‘ubuntu/trusty64’ version ‘20190429.0.1’ is up to date…
==> database: Setting the name of the VM: m310-vagrant-env_database_1571260299618_75595
==> database: Clearing any previously set forwarded ports…
==> database: Clearing any previously set network interfaces…
==> database: Preparing network interfaces based on configuration…
database: Adapter 1: nat
database: Adapter 2: hostonly
==> database: Forwarding ports…
database: 22 (guest) => 2222 (host) (adapter 1)
==> database: Running ‘pre-boot’ VM customizations…
==> database: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “6bcba693-a09d-4582-90d7-d1a803398f99”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

1 Like

Hi @Rajesh_Chinni_09970,

Please find the below suggestions which worked for students having the same issue:

Had lots trouble for a while with this error: WHvSetupPartition failed. Finally got it working by “Turn Windows features on or off” in Control Panel and UN-Selecting Containers (also I had Hypervisor disabled).

1-search cmd and run as a administrator
2-execute below command
bcdedit /set hypervisorlaunchtype off
3-Restart the system
4-Problem solved for me atleast finnaly :slight_smile:

Point is to disable Hyper-v in your system. Let me know if these doesn’t work for you, then we will try more solutions.

Kanika

Thank you. Its working now.

1 Like