Problem in setting up vagrant

C:\Users\KARTHI\m103\m103-vagrant-env>vagrant up
Bringing machine ‘mongod-m103’ up with ‘hyperv’ provider…
==> mongod-m103: Verifying Hyper-V is enabled…
==> mongod-m103: Verifying Hyper-V is accessible…
==> mongod-m103: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
mongod-m103: Box Provider: hyperv
mongod-m103: Box Version: >= 0
==> mongod-m103: Loading metadata for box ‘ubuntu/trusty64’
mongod-m103: URL: https://vagrantcloud.com/ubuntu/trusty64
The box you’re attempting to add doesn’t support the provider
you requested. Please find an alternate box or use an alternate
provider. Double-check your requested provider to verify you didn’t
simply misspell it.

If you’re adding a box from HashiCorp’s Vagrant Cloud, make sure the box is
released.

Name: ubuntu/trusty64
Address: https://vagrantcloud.com/ubuntu/trusty64
Requested provider: [:hyperv]

C:\Users\KARTHI\m103\m103-vagrant-env>vagrant ssh
VM must be created before running this command. Run vagrant up first.

image

you are not successful at vagrant up --provision – it does, load the whole mongo db setup.

so you failed at vagrant up --provision – did you have internet connection in the server where you running vagrant up --provision. vagrant up --provision get the whole setup form cloud.

Hi @Karthick_90756,

You need to disable Hyper-V in your windows machine. In addition to this please make sure of the following :

  1. Virtualization is enable in BIOS
  2. You are using VirtualBox version 6.0.14 and not the 6.1 version.

You can also have a look at this thread.

Hope it helps!

Thanks,
Shubham Ranjan
Curriculum Support Engineer

1 Like

Hi @Shubham_Ranjan ,

I have disable Hyper-V and downgraded VirtualBox to 6.0

But i’m facing this issue, Kindly help me to install

Hi @Karthick_90756,

Please open your command prompt and run the following command :

bcdedit /set hypervisorlaunchtype off

Once the operation gets completed then reboot the host machine.

Hope it helps!

Please feel free to get back to us if the issue still persists.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Thank you @Shubham_Ranjan now it is working

Hi @Karthick_90756,

I’m glad your issue got resolved. Please feel free to get back to us if you have any other issue.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Closing the thread as the issue has been resolved.